Bug 653979 - SELinux is preventing /usr/libexec/gsd-datetime-mechanism "search" access on /home.
Summary: SELinux is preventing /usr/libexec/gsd-datetime-mechanism "search" access ...
Keywords:
Status: CLOSED DUPLICATE of bug 653982
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:17f255d5fff...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-16 15:03 UTC by Joachim Frieben
Modified: 2010-11-16 16:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-16 16:33:54 UTC
Type: ---


Attachments (Terms of Use)

Description Joachim Frieben 2010-11-16 15:03:57 UTC
Summary:

SELinux is preventing /usr/libexec/gsd-datetime-mechanism "search" access on
/home.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by gsd-datetime-me. It is not expected that this
access is required by gsd-datetime-me and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:gnomeclock_t:s0-s0:c0.c1023
Target Context                system_u:object_r:home_root_t:s0
Target Objects                /home [ dir ]
Source                        gsd-datetime-me
Source Path                   /usr/libexec/gsd-datetime-mechanism
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gnome-settings-daemon-2.32.0-2.fc14
Target RPM Packages           filesystem-2.4.35-1.fc14
Policy RPM                    selinux-policy-3.9.7-10.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.35.8-59.fc14.x86_64 #1 SMP Tue
                              Nov 16 03:32:03 UTC 2010 x86_64 x86_64
Alert Count                   8
First Seen                    Tue 16 Nov 2010 02:42:11 PM CET
Last Seen                     Tue 16 Nov 2010 04:03:04 PM CET
Local ID                      5bdae275-f0a8-4b7d-9e74-5fe5d61bb8f2
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1289919784.241:31431): avc:  denied  { search } for  pid=2881 comm="gsd-datetime-me" name="/" dev=dm-2 ino=2 scontext=system_u:system_r:gnomeclock_t:s0-s0:c0.c1023 tcontext=system_u:object_r:home_root_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1289919784.241:31431): avc:  denied  { dac_override } for  pid=2881 comm="gsd-datetime-me" capability=1  scontext=system_u:system_r:gnomeclock_t:s0-s0:c0.c1023 tcontext=system_u:system_r:gnomeclock_t:s0-s0:c0.c1023 tclass=capability

node=(removed) type=AVC msg=audit(1289919784.241:31431): avc:  denied  { search } for  pid=2881 comm="gsd-datetime-me" name="frieben" dev=dm-2 ino=3407875 scontext=system_u:system_r:gnomeclock_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=dir

node=(removed) type=AVC msg=audit(1289919784.241:31431): avc:  denied  { search } for  pid=2881 comm="gsd-datetime-me" name="lib64" dev=dm-2 ino=3407980 scontext=system_u:system_r:gnomeclock_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1289919784.241:31431): arch=c000003e syscall=2 success=no exit=-2 a0=7fffe111e5d0 a1=0 a2=0 a3=4 items=0 ppid=2880 pid=2881 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="gsd-datetime-me" exe="/usr/libexec/gsd-datetime-mechanism" subj=system_u:system_r:gnomeclock_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,gsd-datetime-me,gnomeclock_t,home_root_t,dir,search
audit2allow suggests:

#============= gnomeclock_t ==============
allow gnomeclock_t home_root_t:dir search;
allow gnomeclock_t self:capability dac_override;
allow gnomeclock_t user_home_dir_t:dir search;
allow gnomeclock_t user_home_t:dir search;

Comment 1 Daniel Walsh 2010-11-16 16:33:54 UTC

*** This bug has been marked as a duplicate of bug 653982 ***


Note You need to log in before you can comment on or make changes to this bug.