Bug 654235 - [RFE] Modules implementing filters for their files
[RFE] Modules implementing filters for their files
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: sos (Show other bugs)
rawhide
All All
low Severity medium
: ---
: ---
Assigned To: Bryn M. Reeves
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-17 04:43 EST by Pierre Carrier
Modified: 2017-02-23 11:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-23 11:44:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github sosreport/sos/issues/941 None None None 2017-02-23 11:44 EST

  None (edit)
Description Pierre Carrier 2010-11-17 04:43:45 EST
Problem:
- Files such as /etc/passwd are not included
- I don't think anyone is comfortable adding them because the data they contain is particularly sensible.

Approach:
- For /etc/passwd for example, replacing the account field by its SHA-1, every character in the GECOS field by 'x' would still allow a support engineer to determine if a username is defined there, if yes its shell, etc.
- Such filters belong in the module itself and not in the core of sosreport

Proposed solution:

- When including the file, the module should be able to specify a filter method.
- We should allow per-line filters (fast and simple), filters that receive the file contents as a string and return the stored contents as another
Comment 1 Fedora Admin XMLRPC Client 2012-02-25 08:50:28 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Admin XMLRPC Client 2012-02-27 08:59:40 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Sandro Bonazzola 2017-02-23 11:44:40 EST
The problem described has been moved upstream in 
https://github.com/sosreport/sos/issues/941

Note You need to log in before you can comment on or make changes to this bug.