Bug 654260 - ibus crashes.
ibus crashes.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-17 05:45 EST by sangu
Modified: 2010-11-18 00:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-18 00:45:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description sangu 2010-11-17 05:45:23 EST
Description of problem:
$ gdb /usr/bin/ibus-daemon coredump 

Core was generated by `/usr/bin/ibus-daemon --xim'.
Program terminated with signal 11, Segmentation fault.
#0  _ic_process_key_event (context=0x16b5d10, 
    parameters=<value optimized out>, invocation=0x168a700)
    at inputcontext.c:698
698	        if (context == NULL ||
Missing separate debuginfos, use: debuginfo-install glibc-2.12.90-18.x86_64 libselinux-2.0.96-5.fc14.x86_64 zlib-1.2.5-2.fc14.x86_64
(gdb) bt
#0  _ic_process_key_event (context=0x16b5d10 [BusInputContext], 
    parameters=<value optimized out>, invocation=0x168a700)
    at inputcontext.c:698
#1  0x00007fcebbd545cd in call_in_idle_cb (user_data=<value optimized out>)
    at gdbusconnection.c:4423
#2  0x00007fcebb1813af in g_main_dispatch (context=0x168ca80) at gmain.c:2267
#3  g_main_context_dispatch (context=0x168ca80) at gmain.c:2824
#4  0x00007fcebb181bc0 in g_main_context_iterate (context=0x168ca80, block=1, 
    dispatch=1, self=<value optimized out>) at gmain.c:2902
#5  0x00007fcebb182292 in g_main_loop_run (loop=0x165f350) at gmain.c:3110
#6  0x00000000004145bc in bus_server_run () at server.c:81
#7  0x00000000004060c9 in main (argc=1, argv=0x7fff2b680f18) at main.c:276

Version-Release number of selected component (if applicable):
1.3.99.20101028-2.fc15.x86_64

How reproducible:
sometimes

Steps to Reproduce:
1. switching another window (alt + tab)
2.
3.
  
Actual results:


Expected results:


Additional info:
glib2-2.27.3-1.fc15.x86_64
Comment 1 fujiwara 2010-11-17 22:46:33 EST
Thx for testing rawhide.

I cannot reproduce this problem but it's good to check NULL from the stack.
https://github.com/fujiwarat/ibus/commit/265931288cf08ddc1da952dd4e1e398c238c2b7d

I'll integrate the fix in rawhide.

Note You need to log in before you can comment on or make changes to this bug.