Bug 654367 - runuser prompts password even when called by root
runuser prompts password even when called by root
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
: 654675 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-17 12:26 EST by Mamoru TASAKA
Modified: 2010-11-19 00:51 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-19 00:51:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2010-11-17 12:26:25 EST
Description of problem:
On rawhide:

[root@localhost ~]# service groonga status
grn_ctx_connect failed (127.0.0.1:10041)
[root@localhost ~]# service groonga start
Starting groonga (via systemctl):  Job failed. See system logs and 'systemctl status' for details.
                                                           [失敗]

Currently I have no idea what this message means.

Version-Release number of selected component (if applicable):
groonga-1.0.3-1.fc15.i686
initscripts-9.22-2.fc15.i686
systemd-12-3.fc15.i686


How reproducible:
100%
Comment 1 Daiki Ueno 2010-11-17 22:57:30 EST
After looking at the output of strace, I think this is due to the bug of runuser program in coreutils, used by daemon() in initscripts:

$ su
# id
uid=0(root) gid=0(root) groups=0(root),1(bin),2(daemon),3(sys),4(adm),6(disk),10(wheel) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
# runuser -s /bin/bash nobody
runuser: incorrect password

Actually it seems that coreutils-8.7-runuser.patch was recently added to coreutils-8.7-1.fc15.
Comment 2 Ondrej Vasik 2010-11-18 00:56:17 EST
Thanks for report, it's likely, due to heavy changes caused by adopting new PAM patch. Will check where is the problem.
Comment 3 Ondrej Vasik 2010-11-18 10:31:27 EST
*** Bug 654675 has been marked as a duplicate of this bug. ***
Comment 4 Ondrej Vasik 2010-11-18 14:07:30 EST
coreutils-8.7-2.fc15 should fix the issue ( http://koji.fedoraproject.org/koji/buildinfo?buildID=205449 ) ...
Comment 5 Mamoru TASAKA 2010-11-18 16:29:26 EST
Seems good, thank you.

# rpm -q coreutils groonga
coreutils-8.7-2.fc15.i686
groonga-1.0.3-1.fc15.i686
# service groonga start
Starting groonga (via systemctl):                          [  OK  ]
# service groonga status
[[0,1290115689.94847,0.085431876],{"alloc_count":141,"starttime":1290115687,"uptime":3,"version":"1.0.3","n_queries":0,"cache_hit_rate":0.0,"command_version":1,"default_command_version":1,"max_command_version":2}]
# runuser -s /bin/bash nobody
bash-4.1$ exit
Comment 6 Ondrej Vasik 2010-11-19 00:51:10 EST
Thanks for confirmation, closing RAWHIDE...

Note You need to log in before you can comment on or make changes to this bug.