Bug 65437 - rpm won't take my spec file.
rpm won't take my spec file.
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: rpm-build (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-23 23:47 EDT by hjl
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 17:46:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
My spec file. (329 bytes, text/plain)
2002-05-23 23:47 EDT, hjl
no flags Details
This patch will fix the issue (at least it works for me) (2.45 KB, patch)
2002-06-27 16:54 EDT, Dan Yefimov
no flags Details | Diff
Here is my version (3.94 KB, patch)
2002-06-27 17:00 EDT, hjl
no flags Details | Diff

  None (edit)
Description hjl 2002-05-23 23:47:21 EDT
I got
Building target platforms: alpha
Building for target alpha
error: parse error in expression
error: /export/redhat/baseline/dummy/dummy.spec:18: parseExpressionBoolean retur
ns -1
Executing(%prep): /bin/sh -e /var/tmp/alpha-linux/rpm-tmp.23970
+ umask 022
+ cd /export/redhat/rpms/BUILD
+ cd /export/redhat/rpms/BUILD
+ rm -rf dummy
+ /bin/mkdir -p dummy
+ cd dummy
++ /usr/bin/id -u
+ '[' 1103 = 0 ']'
++ /usr/bin/id -u
+ '[' 1103 = 0 ']'
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/alpha-linux/rpm-tmp.23970
+ umask 022
+ cd /export/redhat/rpms/BUILD
+ cd dummy
+ exit 0
Comment 1 hjl 2002-05-23 23:47:57 EDT
Created attachment 58365 [details]
My spec file.
Comment 2 Dan Yefimov 2002-06-27 16:54:59 EDT
Created attachment 62945 [details]
This patch will fix the issue (at least it works for me)
Comment 3 hjl 2002-06-27 17:00:56 EDT
Created attachment 62946 [details]
Here is my version
Comment 4 Dan Yefimov 2002-06-27 17:17:35 EDT
Your patch doesn't completely solve the problem, it just masks it off. My
version does remove the root of the problem - it just skips processing
conditionals that shouldn't be processed anyway because they're inside the false
branch of the outer conditional.
Comment 5 Bill Nottingham 2005-09-29 17:46:18 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

For RPM issues, please try a current release such as Fedora Core 4; if bugs
persist, please open a new issue.

Note You need to log in before you can comment on or make changes to this bug.