Bug 65466 - ggv cannot show any PDF file
ggv cannot show any PDF file
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ggv (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-24 13:00 EDT by David Miller
Modified: 2013-04-02 00:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-30 07:35:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for GGV so it can view PDF files properly. (478 bytes, patch)
2002-05-24 13:01 EDT, David Miller
no flags Details | Diff

  None (edit)
Description David Miller 2002-05-24 13:00:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
Trying to view any PDF file with ggv fails
because the arguments to ghostscript are
not composed properly.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.ggv anyfile.pdf
2.
3.
	

Actual Results:  sh: -c: line 1: unexpected EOF while looking for matching `"'
sh: -c: line 2: syntax error: unexpected end of file


Expected Results:  ggv would show me the PDF file


Additional info:

There are only two %s's in the format
string used to compose the ghostscript invocation
(for the two filenames) but the sprintf call thinks
there are more.

I will attach a patch that fixes the bug.
Comment 1 David Miller 2002-05-24 13:01:47 EDT
Created attachment 58426 [details]
Fix for GGV so it can view PDF files properly.
Comment 2 Nakai 2002-07-30 07:35:40 EDT
Still in beta4.

Note You need to log in before you can comment on or make changes to this bug.