This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 654678 - rpclib.py is missing _strip_characters function and call
rpclib.py is missing _strip_characters function and call
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhnlib (Show other bugs)
4.8
All All
high Severity high
: rc
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
: ZStream
Depends On:
Blocks: 655034
  Show dependency treegraph
 
Reported: 2010-11-18 10:23 EST by Martin Poole
Modified: 2012-06-14 16:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Due to an error in one of the previous update, rhnlib did not remove control characters from the XML-RPC communication during a registration to Red Hat Network or Red Hat Network Satellite Server. With this update, this error has been fixed, and such characters are now stripped as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 16:55:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Poole 2010-11-18 10:23:20 EST
Description of problem:

recent update to rhnlib and up2date to handle non-ascii character is missing the code in rpclib.py used in the rhel5 & rhel6 versions which ensures all non-xml compliant characters are removed from from messages prior to transmission.

this shortcoming means control characters and the like can reach the satellite and cause registration failures.

Version-Release number of selected component (if applicable):

rhnlib-2.1.4-17.el4


Additional info:

<name>smbios.system.skunumber</name>
<value><string>^P^C^C^E</string></value>
Comment 2 Miroslav Suchý 2010-11-18 10:29:38 EST
the changes are in svn, we will need just to build new package.
Comment 5 Jaromir Hradilek 2010-11-24 11:47:43 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Due to an error in one of the previous update, rhnlib did not remove control characters from the XML-RPC communication during a registration to Red Hat Network or Red Hat Network Satellite Server. With this update, this error has been fixed, and such characters are now stripped as expected.

Note You need to log in before you can comment on or make changes to this bug.