Bug 654733 - planner-eds doesn't implement all methods required by ECalBackendSync
Summary: planner-eds doesn't implement all methods required by ECalBackendSync
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: planner
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:4111345328a42afad755e5e149f...
: 658797 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-18 18:02 UTC by Rafael
Modified: 2010-12-03 20:42 UTC (History)
3 users (show)

Fixed In Version: planner-0.14.4-27.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-03 20:42:49 UTC


Attachments (Terms of Use)
File: backtrace (33.09 KB, text/plain)
2010-11-18 18:02 UTC, Rafael
no flags Details

Description Rafael 2010-11-18 18:02:17 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/e-calendar-factory
component: evolution-data-server
crash_function: raise
executable: /usr/libexec/e-calendar-factory
kernel: 2.6.35.6-48.fc14.x86_64
package: evolution-data-server-2.32.0-3.fc14
rating: 4
reason: Process /usr/libexec/e-calendar-factory was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1290102901
uid: 500

Comment 1 Rafael 2010-11-18 18:02:21 UTC
Created attachment 461346 [details]
File: backtrace

Comment 2 Milan Crha 2010-11-19 08:09:20 UTC
Thanks for a bug report. The ECalBackendPlanner doesn't implement set_default_zone_sync, as indicates the message:
> #2  0x00007ff924ef3584 in g_assertion_message (domain=<value optimized out>,
> file=<value optimized out>, line=<value optimized out>, func=0x7ff928e428c0
> "e_cal_backend_sync_set_default_zone", message=0xd3a790 "assertion failed:
> (E_CAL_BACKEND_SYNC_GET_CLASS (backend)->set_default_zone_sync)") at
> gtestutils.c:1358
>    lstr = "485\000\377\177\000\000\240H\000\b\371\177\000\000\000\000\000
>  \000\000\000\000\000\210'\344(\371\177\000"
>        s = 0xd45a30 "libedata-cal:ERROR:e-cal-backend-
< sync.c:485:e_cal_backend_sync_set_default_zone: assertion failed:
> (E_CAL_BACKEND_SYNC_GET_CLASS (backend)->set_default_zone_sync)"

I'm moving this to that package.

Comment 3 Caolan McNamara 2010-11-19 09:35:27 UTC
Bah, the real problem IMO is that eds changes its api every now and then without a migration guide.

Comment 4 Caolan McNamara 2010-11-19 09:39:31 UTC
Lets use the old set_default_timezone_sync stub and hope for the best

Comment 5 Fedora Update System 2010-11-19 09:44:57 UTC
planner-0.14.4-27.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/planner-0.14.4-27.fc14

Comment 6 Fedora Update System 2010-11-19 22:39:06 UTC
planner-0.14.4-27.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update planner'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/planner-0.14.4-27.fc14

Comment 7 Milan Crha 2010-12-01 11:33:37 UTC
*** Bug 658797 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2010-12-03 20:42:44 UTC
planner-0.14.4-27.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.