Bug 65502 - system hangs on shutdown due to umount /usr failure
system hangs on shutdown due to umount /usr failure
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
http://groups.google.com/groups?hl=en...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-25 22:08 EDT by Need Real Name
Modified: 2014-03-16 22:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-27 17:12:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-25 22:08:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0+) Gecko/20020427

Description of problem:
When shutting down my systems (2 of them), they show the error:

Turning off quotas  [ok]
Unmounting file systems: umount2: Device or resource busy
umount: /dev/hda8: Not mounted
umount: /usr: illegal seek [failed]

INIT: no more processes left in this runlevel

Then hang.  I am forced to turn the sytem off which cause a FS check.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Install redhat linux 7.3 only with core packages
2.  reboot
	

Actual Results:  system hangs with:

Turning off quotas  [ok]
Unmounting file systems: umount2: Device or resource busy
umount: /dev/hda8: Not mounted
umount: /usr: illegal seek [failed]

INIT: no more processes left in this runlevel


Expected Results:  system umount /usr and shutdown gracefully

Additional info:

The system has a dell perc3 dcl raid 5 controller and a logical disk array, 1G
of ram, and (2) 1.2 ghz cpus.

Running on redhat kernel 2.4.18-4.

This looks simular to bug 25744 but I don't think it is the same.
Comment 1 Need Real Name 2002-05-27 17:11:55 EDT
Ok, I went to trouble-shoot as described in bug 25744 and found that
/usr/local/lib/libldap.so.2.0.15 and /usr/local/lib/liblber.so.2.0.15 where
being used by S01reboot.

The reason why these exist in /usr/local/lib is because I removed the RH
openldap libraries and compiled my own openldap server.

I was able to resolve the issue by coping in the libraries and symlinks to /lib:

cp -R /usr/local/lib/libldap* /usr/local/lib/liblber* /lib
ldconfig

At this point I am not sure that this is a bug, but I don't understand why
reboot would need these libraries.

thanks,

schu  

Comment 2 Bill Nottingham 2002-05-28 11:56:23 EDT
If you're using LDAP for user information, it's needed in the bootup process...
since this works with the way we ship our LDAP libraries, I'm closing it as not
a but.
Comment 3 Need Real Name 2002-05-28 12:33:18 EDT
Do you know which binary calls the ldap libraries?  I looked for a while and
couldn't find it.
Comment 4 Bill Nottingham 2002-05-28 12:37:59 EDT
Anything that tries to get user information (home dir, uid, gid) will go through
the NSS services; if you're using LDAP, that will use the LDAP libraries.

Note You need to log in before you can comment on or make changes to this bug.