Bug 655177 - [abrt] system-config-printer-1.2.4-1.fc13: libxml2.py:1:<module>:ImportError: /usr/lib64/python2.6/site-packages/libxml2mod.so: symbol xmlFirstElementChild, version LIBXML2_2.7.3 not defined in file libxml2.so.2 with link time reference
Summary: [abrt] system-config-printer-1.2.4-1.fc13: libxml2.py:1:<module>:ImportError:...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: libxml2
Version: 13
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b6f276bc
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-19 19:36 UTC by Andrew Dunstan
Modified: 2010-11-22 20:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-22 20:06:21 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (6.93 KB, text/plain)
2010-11-19 19:36 UTC, Andrew Dunstan
no flags Details

Description Andrew Dunstan 2010-11-19 19:36:54 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
component: system-config-printer
executable: /usr/share/system-config-printer/system-config-printer.py
kernel: 2.6.34.7-56.fc13.x86_64
package: system-config-printer-1.2.4-1.fc13
reason: libxml2.py:1:<module>:ImportError: /usr/lib64/python2.6/site-packages/libxml2mod.so: symbol xmlFirstElementChild, version LIBXML2_2.7.3 not defined in file libxml2.so.2 with link time reference
release: Fedora release 13 (Goddard)
time: 1290195128
uid: 500

How to reproduce
-----
1. system-config-printer

Comment 1 Andrew Dunstan 2010-11-19 19:36:56 UTC
Created attachment 461634 [details]
File: backtrace

Comment 2 Jiri Popelka 2010-11-22 10:47:14 UTC
Thank you for the report.

What does 'rpm -q libxml2-python' show ?

Comment 3 Andrew Dunstan 2010-11-22 12:17:48 UTC
it shows: libxml2-python-2.7.7-1.fc13.x86_64

Comment 4 Andrew Dunstan 2010-11-22 20:06:21 UTC
Apologies for the noise. I just discovered that this was caused by a piece of third party software which installed an incompatible library on my system and conveniently added itself to the default LD search path by loiing a file in /etc/ld.so.conf.d. I'll be raising hell with them.


Note You need to log in before you can comment on or make changes to this bug.