Bug 65527 - --preferxf3 not working
--preferxf3 not working
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-26 20:32 EDT by Michael Stenner
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-30 08:19:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config generated by Xconfigurator (12.60 KB, text/plain)
2002-05-27 19:55 EDT, Michael Stenner
no flags Details
XF86Config-4 created by Xconfigurator (1.85 KB, text/plain)
2002-05-27 19:57 EDT, Michael Stenner
no flags Details
output of lspci - I have an S3 Virge clone (that's why I want to use 3) (303 bytes, text/plain)
2002-05-27 19:58 EDT, Michael Stenner
no flags Details
X server output after running Xconfigurator WITH the --preferxf3 option (2.10 KB, text/plain)
2002-05-27 19:59 EDT, Michael Stenner
no flags Details
X server output after running Xconfigurator with --preferxf3 AND changing /usr/X11R6/bin/X (6.49 KB, text/plain)
2002-05-27 20:01 EDT, Michael Stenner
no flags Details

  None (edit)
Description Michael Stenner 2002-05-26 20:32:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020509

Description of problem:
--preferxf3 doesn't seem to be working.  Specifically, X4 is still run both from
gdm and startx.  It looks like /usr/X11R6/bin/X still links to XFree86 (in the
same dir), which is the X4 server.

/etc/X11/X points to the right place, but doesn't seem to be used any more.

using Xconfigurator-4.10.7-1


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install (x4 is used by default)
2. run "Xconfigurator --preferxf3"
3. run X (either from gdm or startx)	

Actual Results:  It runs X4... I"m real sure it's X4 :)

Note that it doesn't change /usr/X11R6/bin/X at all.  I manually linked it to
XF86_SVGA (to make stuff work right with my S3) and then ran Xconfigurator again
(EXACTLY as I did before) and it left the link alone.

Additional info:
Comment 1 Mike A. Harris 2002-05-27 09:28:56 EDT
--preferxf3 only works if the Cards database has an actual XFree86 server
entry for the given card.  If not, then either it isn't supported, or it
is a bug in the database perhaps.

You haven't indicated what video card you're using, so I'll need more
information to conclude.

Attach X server log, X config files (both), and the output of "lspci -n"
Comment 2 Michael Stenner 2002-05-27 19:55:42 EDT
Created attachment 58709 [details]
XF86Config generated by Xconfigurator
Comment 3 Michael Stenner 2002-05-27 19:57:10 EDT
Created attachment 58710 [details]
XF86Config-4 created by Xconfigurator
Comment 4 Michael Stenner 2002-05-27 19:58:29 EDT
Created attachment 58711 [details]
output of lspci - I have an S3 Virge clone (that's why I want to use 3)
Comment 5 Michael Stenner 2002-05-27 19:59:29 EDT
Created attachment 58712 [details]
X server output after running Xconfigurator WITH the --preferxf3 option
Comment 6 Michael Stenner 2002-05-27 20:01:20 EDT
Created attachment 58713 [details]
X server output after running Xconfigurator with --preferxf3 AND changing /usr/X11R6/bin/X
Comment 7 Michael Stenner 2002-05-27 20:11:23 EDT
I've just given you a flood of info.  Let me know if any more will be useful. 
Here are some relevant facts:

1) Xconfigurator IS rewriting the XF86Config files (based on timestamps)

2) Xconfigurator IS recognizing the card.  In the first little menu, it tells
   me what the card is and what server it will use.

3) Xconfigurator IS changing the /etc/X11/X symlink, but not /usr/X11R6/bin/X,
   which is the one that gets used by gdm and startx.
Comment 8 Mike A. Harris 2002-12-30 08:19:37 EST
The best solution here is to use 4.x with the "vesa" driver if the native
driver does not work.  There is a glitch in Xconfigurator which doesn't set
up the X server symlink correctly in all cases, however since there is a simple
enough workaround of using the 4.x server, and Xconfigurator is now officially
deprecated, there wont be further Xconfigurator updates except if there
are secuirty bugs found in it, which is unlikely.

Unfortunately, the problem here existed through 5 beta releases and nobody
ever reported it to us, so it never got detected and fixed in the 7.3 release.
There's not much point in fixing it now due to the workaround above.

This should work automatically in our current release of Red Hat Linux 8.0
with the new tool.

Closing as CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.