Bug 655442 - SELinux is preventing /usr/libexec/gam_server "search" access on /var/cache/yum.
Summary: SELinux is preventing /usr/libexec/gam_server "search" access on /var/ca...
Keywords:
Status: CLOSED DUPLICATE of bug 655441
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:bb619382e6b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-20 23:25 UTC by Robert G. 'Doc' Savage
Modified: 2010-11-30 22:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-22 09:22:35 UTC
Type: ---


Attachments (Terms of Use)

Description Robert G. 'Doc' Savage 2010-11-20 23:25:21 UTC
Summary:

SELinux is preventing /usr/libexec/gam_server "search" access on /var/cache/yum.

Detailed Description:

SELinux denied access requested by gam_server. It is not expected that this
access is required by gam_server and this access may signal an intrusion
attempt. It is also possible that the specific version or configuration of the
application is causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:fail2ban_t:s0
Target Context                system_u:object_r:rpm_var_cache_t:s0
Target Objects                /var/cache/yum [ dir ]
Source                        gam_server
Source Path                   /usr/libexec/gam_server
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gamin-0.1.10-8.fc14
Target RPM Packages           yum-3.2.28-5.fc14
Policy RPM                    selinux-policy-3.9.7-10.fc14
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux localhost.localdomain
                              2.6.35.6-48.fc14.x86_64 #1 SMP Fri Oct 22 15:36:08
                              UTC 2010 x86_64 x86_64
Alert Count                   238
First Seen                    Sat 20 Nov 2010 05:08:37 PM CST
Last Seen                     Sat 20 Nov 2010 05:24:25 PM CST
Local ID                      ec8e0ae8-d3a0-4562-a8a6-3ce94c7841b9
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1290295465.927:2675): avc:  denied  { search } for  pid=2331 comm="gam_server" name="yum" dev=sda2 ino=6815749 scontext=system_u:system_r:fail2ban_t:s0 tcontext=system_u:object_r:rpm_var_cache_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1290295465.927:2675): arch=c000003e syscall=254 success=no exit=-13 a0=3 a1=2282380 a2=1002fc6 a3=0 items=0 ppid=1 pid=2331 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="gam_server" exe="/usr/libexec/gam_server" subj=system_u:system_r:fail2ban_t:s0 key=(null)



Hash String generated from  catchall,gam_server,fail2ban_t,rpm_var_cache_t,dir,search
audit2allow suggests:

#============= fail2ban_t ==============
allow fail2ban_t rpm_var_cache_t:dir search;

Comment 1 Miroslav Grepl 2010-11-22 09:22:35 UTC

*** This bug has been marked as a duplicate of bug 655441 ***


Note You need to log in before you can comment on or make changes to this bug.