Bug 655447 - [abrt] gnome-color-manager-2.32.0-2.fc14: Process /usr/bin/gcm-apply was killed by signal 6 (SIGABRT)
Summary: [abrt] gnome-color-manager-2.32.0-2.fc14: Process /usr/bin/gcm-apply was kill...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-color-manager
Version: 14
Hardware: i686
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9f362984768bbe02b728bfc6a40...
Depends On:
Blocks: 531755
TreeView+ depends on / blocked
 
Reported: 2010-11-20 23:57 UTC by Michal Ambroz
Modified: 2012-01-23 15:38 UTC (History)
3 users (show)

Fixed In Version: FC16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-23 15:38:27 UTC


Attachments (Terms of Use)
File: backtrace (16.86 KB, text/plain)
2010-11-20 23:57 UTC, Michal Ambroz
no flags Details
File: reproduce (3.20 KB, text/plain)
2010-11-20 23:57 UTC, Michal Ambroz
no flags Details

Description Michal Ambroz 2010-11-20 23:57:01 UTC
abrt version: 1.1.13
architecture: i686
Attached file: backtrace
cmdline: /usr/bin/gcm-apply
component: gnome-color-manager
executable: /usr/bin/gcm-apply
kernel: 2.6.35.6-48.fc14.i686
package: gnome-color-manager-2.32.0-2.fc14
rating: 4
reason: Process /usr/bin/gcm-apply was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
Attached file: reproduce
time: 1289950616
uid: 42

Comment 1 Michal Ambroz 2010-11-20 23:57:03 UTC
Created attachment 461787 [details]
File: backtrace

Comment 2 Michal Ambroz 2010-11-20 23:57:06 UTC
Created attachment 461788 [details]
File: reproduce

Comment 3 Michal Ambroz 2010-11-21 00:00:17 UTC
What happened for this core dump:
1. System boots
2. gcm-apply is started many times (20+) (sreen flashes many times)
3. Some of these processes probably have been found blocking and were killed with SIGABRT.


Similar behaviour can be observed when starting the gcm-prefs or changing  in gcm-prefs from one profile to another. There is 1:3 that extensive number of gcm-apply processes is started.

Same happens from example when sceensaver dimms the screen and is bringed back to operation or when notebook lid is closed and reopened. 

Screen flickers at that time and each flash is blocking input devices so it limits usability of the environment. Sometimes it is 10 sometimes it is 50 of processes. After a while these flashes usually stop and all gcm-apply processes are gone.

[mambroz@czchownmambroz fc14]$ ps axo stat,euid,ruid,tty,tpgid,sess,pgrp,ppid,pid,pcpu,comm |grep gcm
Sl     500   500 ?           -1  5462  5462     1 21521  3.3 gcm-prefs
S      500   500 ?           -1  5552  5552     1 21527  0.3 gcm-apply
S      500   500 ?           -1  5552  5552     1 21529  0.0 gcm-apply
S      500   500 ?           -1  5552  5552     1 21531  0.0 gcm-apply
S      500   500 ?           -1  5552  5552     1 21533  0.4 gcm-apply
S      500   500 ?           -1  5552  5552     1 21535  0.2 gcm-apply
S      500   500 ?           -1  5552  5552     1 21537  0.0 gcm-apply
S      500   500 ?           -1  5552  5552     1 21539  0.2 gcm-apply
S      500   500 ?           -1  5552  5552     1 21541  0.2 gcm-apply
S      500   500 ?           -1  5552  5552     1 21543  0.2 gcm-apply
S      500   500 ?           -1  5552  5552     1 21545  0.2 gcm-apply
S      500   500 ?           -1  5552  5552     1 21547  0.0 gcm-apply

[mambroz@czchownmambroz fc14]$ ps axo stat,euid,ruid,tty,tpgid,sess,pgrp,ppid,pid,pcpu,comm |grep gcm
Sl     500   500 ?           -1  5462  5462     1 21521  0.5 gcm-prefs
Sl     500   500 ?           -1  5552  5552     1 21681  0.1 gcm-apply
Sl     500   500 ?           -1  5552  5552     1 21683  0.1 gcm-apply
Sl     500   500 ?           -1  5552  5552     1 21685  0.1 gcm-apply
Sl     500   500 ?           -1  5552  5552     1 21687  0.3 gcm-apply
Sl     500   500 ?           -1  5552  5552     1 21689  0.3 gcm-apply
Sl     500   500 ?           -1  5552  5552     1 21691  0.2 gcm-apply
S      500   500 ?           -1  5552  5552     1 21700  0.5 gcm-apply
S      500   500 ?           -1  5552  5552     1 21702  0.0 gcm-apply
S      500   500 ?           -1  5552  5552     1 21704  0.0 gcm-apply
[mambroz@czchownmambroz fc14]$ ps axo stat,euid,ruid,tty,tpgid,sess,pgrp,ppid,pid,pcpu,comm |grep gcm
Sl     500   500 ?           -1  5462  5462     1 21521  0.5 gcm-prefs
Sl     500   500 ?           -1  5552  5552     1 21700  0.3 gcm-apply
Sl     500   500 ?           -1  5552  5552     1 21702  0.3 gcm-apply
Sl     500   500 ?           -1  5552  5552     1 21704  0.3 gcm-apply
S      500   500 ?           -1  5552  5552     1 21714  0.2 gcm-apply
S      500   500 ?           -1  5552  5552     1 21716  0.2 gcm-apply
S      500   500 ?           -1  5552  5552     1 21718  0.0 gcm-apply

As a workaround it is possible to uninstall gnome-color-manager. 

Hardware is  HP EliteBook 6930p .

Best regards
Michal Ambroz

Comment 4 Richard Hughes 2010-11-22 08:53:08 UTC
What is the output of "gcm-apply -v"? Does the process hang at a specific point? If so, can you grab the output using gdb please?

I think this is a GConf bug, not a gnome-color-manager bug, but want to be sure.

Comment 5 Michal Ambroz 2010-11-22 13:16:53 UTC
The problem is the gcm-apply usually doesn't hang. 
The one which was killed by system when abrt generated this report was exception and I believe the backtrace is probably not much of the use. I believe that at that time too many of instances of gcm-apply was executed simultaneously so the system got stucked completely.

I can see that as soon as the "bad" thing happens a lot of gcm-apply is started on the background. As you can see from the process listing new and new instances 
are started as the old ones finish the job.

PPID is 1 so I do not know what is starting them - udev maybe?

I will try to reboot to Linux at the evening and provide the gcm-apply -v, but I would say every one of the gcm-apply is fine and sets the screen colors. Problem is that too many of them is started at the same moment.

Michal

Comment 6 Sean Beeson 2011-05-12 11:28:16 UTC
I am yet another person getting this screen flicker running fedora 14 with many
gcm-applys starting sometimes after exiting the screen saver. I tried
uninstalling gnome-color-manager, but that leaves me with out a manger and on
bootup I am simply left at an endless screen test. This is happening on a HP
Elitebook 6930p. I have to use intel_iommu=off at the boot options to not have
any problems with the graphics. That boot option works sometimes and sometimes
it doesn't. Under Fedora 13 it worked most of the time.

I have the same hardware as Michal Ambroz

Comment 7 Michal Ambroz 2012-01-23 15:38:27 UTC
I do not have issues on FC16 ... consider it solved.


Note You need to log in before you can comment on or make changes to this bug.