Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 655452 - The src.rpm doesn't build
Summary: The src.rpm doesn't build
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: libcaca
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-21 01:41 UTC by Zenon Panoussis
Modified: 2011-07-11 12:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-11 12:39:46 UTC
Type: ---


Attachments (Terms of Use)

Description Zenon Panoussis 2010-11-21 01:41:01 UTC
Attempting to build the src.rpm fails with errors like this:
org_zoy_caca_Attribute.c:14:18: error: caca.h: No such file or directory

I tried the src.rpm from fc12, fc13, fc14 and epel-el6b. They all have the same problem, but in different places. None of them builds. 

Bootstrapping the package with itself (install libcaca and libcaca-devel, then build) allows the source rpm to build.

Comment 1 Matthias Saou 2010-12-04 12:58:04 UTC
I've just tested a clean mock build with a Fedora 14 x86_64 root and it built fine (the latest libcaca-0.99-0.10.beta17.src.rpm). How are you rebuilding? On a real system using rpmbuild or using minimal roots with something like mock? If on a real system, I'd really recommend using a minimal build root instead. If you manage to identify packages causing problems, then I'd be glad to add BuildConflicts: to the spec file.

Comment 2 Zenon Panoussis 2010-12-09 18:12:41 UTC
I was building it with rpmbuild on a normal RHEL6 system, having added the non-RHEL dependencies from epel/fedora. 

Irrespective of the build system, it seems strange to me that it's looking for caca.h on the system itself; it should be looking for it in its own source instead. It seems that the absolute include paths supplied by rpm are superseding the relative ones of the upstream Makefile.

Comment 3 Matthias Saou 2011-07-11 12:39:46 UTC
You've obviously been hitting some weird issue related to your installed system's environment. It's definitely not normal, but it's not something that's worth spending time trying to figure out.

I'd really recommend you set up a simple mock configuration for RHEL6 and build with that.

I once more just tried mock builds for EL6 and F15, and both went just fine.

If you did/do manage to figure out the problem and want something to be changed in the spec file in order to fix it, please do reopen this report with all of the relevant details.


Note You need to log in before you can comment on or make changes to this bug.