Bug 65566 - kde-i18n-German mystery, missing files after upgrade
kde-i18n-German mystery, missing files after upgrade
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
athlon Linux
low Severity low
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-27 14:22 EDT by Michael Schwendt
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-29 14:27:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upgrade.log from fully updated Enigma to Valhalla (49.44 KB, text/plain)
2002-05-27 14:23 EDT, Michael Schwendt
no flags Details

  None (edit)
Description Michael Schwendt 2002-05-27 14:22:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523

Description of problem:
After upgrade from fully updated Enigma to Valhalla, no files from the
kde-i18n-German package can be found despite the package being listed as installed.

From /root/upgrade.log:
Upgrading kde-i18n-German-3.0.0-5.

$ rpm -q kde-i18n-German
kde-i18n-German-3.0.0-5

Package verifies okay:
$ rpm -V kde-i18n-German

But: /usr/share/doc/HTML/de --> empty!

There should be plenty of files in the following dir, too:

$ cd /usr/share/locale/de/LC_MESSAGES
$ rpm -qf *
dia-0.88.1-3
glame-0.6.0-0
gnome-media-1.2.3-4
gqview-0.8.1-5
make-3.79.1-8
mutt-1.2.5.1-1
pavuk-0.9pl28b-2
setuptool-1.8-2

But no files from kde-i18n-German contrary to "rpm -ql" which says there should
be files in that dir.

$ rpm -vvV kde-i18n-German
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Name rdonly mode=0x0
D: ========== +++ kde-i18n-German-3.0.0-5
D: opening  db index       /var/lib/rpm/Depends create mode=0x0
D:   NO     A rpmlib(PayloadFilesHavePrefix) <= 4.0-1   B
rpmlib(VersionedDependencies) = 3.0.3-1
D:   NO     A rpmlib(PayloadFilesHavePrefix) <= 4.0-1   B
rpmlib(CompressedFileNames) = 3.0.4-1
D:   NO     A rpmlib(PayloadFilesHavePrefix) <= 4.0-1   B rpmlib(PayloadIsBzip2)
= 3.0.5-1
D:   YES    A rpmlib(PayloadFilesHavePrefix) <= 4.0-1   B
rpmlib(PayloadFilesHavePrefix) = 4.0-1
D:  Requires: rpmlib(PayloadFilesHavePrefix) <= 4.0-1       YES (rpmlib provides)
D:   NO     A rpmlib(CompressedFileNames) <= 3.0.4-1    B
rpmlib(VersionedDependencies) = 3.0.3-1
D:   YES    A rpmlib(CompressedFileNames) <= 3.0.4-1    B
rpmlib(CompressedFileNames) = 3.0.4-1
D:  Requires: rpmlib(CompressedFileNames) <= 3.0.4-1        YES (rpmlib provides)
D: opening  db index       /var/lib/rpm/Conflictname rdonly mode=0x0
D: closed   db index       /var/lib/rpm/Depends
D: verify: running %verify script(s) (if any)
D: closed   db index       /var/lib/rpm/Conflictname
D: closed   db index       /var/lib/rpm/Name
D: closed   db index       /var/lib/rpm/Packages


How reproducible:
Didn't try

Steps to Reproduce:
Didn't try. I just upgraded my primary machine from fully updated Enigma to
Valhalla.


Additional info: I had posted about this on valhalla-list long ago, but no one 
has bothered to reply. For me it is a bug, a malfunction. No idea how something
like this could happen. Since I'd like to re-install the kde-i18n-German package
some day, I have reported this here.
Comment 1 Michael Schwendt 2002-05-27 14:23:31 EDT
Created attachment 58705 [details]
upgrade.log from fully updated Enigma to Valhalla
Comment 2 Bernhard Rosenkraenzer 2002-05-28 13:33:21 EDT
Looks like files marked %lang(something) don't get installed on updates.
Comment 3 Jeremy Katz 2002-05-29 11:52:49 EDT
What does your /etc/sysconfig/i18n have in it?
Comment 4 Michael Schwendt 2002-05-29 14:27:49 EDT
Probably going into the right direction, if the installer installs only
supported locales or anything like that:

LANG="en_GB.iso885915"
SUPPORTED="en_GB.iso885915"
LC_ALL=
LINGUAS=
SYSTERM=
SYSFONT="lat0-sun16.psf.gz"
SYSFONTACM="iso15"
UNIMAP=

kdm login is "de", though, and two users have the following in ~/.i18n:

LANG="de_DE@euro"
LC_ALL="de_DE@euro"
LINGUAS=
SYSTERM=
SYSFONT="lat9-16.psf.gz"
SYSFONTACM="iso15"
UNIMAP=
Comment 5 Michael Schwendt 2002-05-29 14:43:13 EDT
rhl-ig-x86-en-7.3/s1-langselection.html : I've chosen British English here.

rhl-ig-x86-en-7.3/s1-langsupport.html : I've not chosen anything else here,
because I've assumed it would upgrade installed packages. It upgraded all
kde-i18n packages, even those I had removed. But it messed my config with
lang-ified packages, so did only install en_GB actually. Hmmm...

Note You need to log in before you can comment on or make changes to this bug.