Bug 65568 - Installer on DPT RAID systems doesn't put dpt_i2o into initrd
Installer on DPT RAID systems doesn't put dpt_i2o into initrd
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-27 14:44 EDT by Terry Letsche
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 11:26:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry Letsche 2002-05-27 14:44:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
On systems with DPT/Adaptec RAID cards using the dpt_i2o module, the installer
correctly loads the driver, but when it comes time to make a boot disk or put
ther kernel on the hard drive, it apparently is not included in the initrd. When
the system reboots, it can't find init, which usually indicates it can't load
the root file system, which in this case is a disk partition controlled by the
DPT card.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RH (upgrade existing RH 7.2 install) on dpt enabled system
2.Reboot at conclusion of install
3.
	

Actual Results:  Systems won't boot. Can't find init.

Expected Results:  Should boot up.

Additional info:

This is on RH 7.2 systems built with Tim Calloway's 7.2 boot floppies. I have
not tried it on a bare system with DPT SCSI card.
Comment 1 Scott D. Webster 2002-05-28 14:49:22 EDT
I'm having a problem where the dpt_i2o driver seems to hang on initialization
during the install.  I don't know if my problem is related to this one.
Comment 2 Michael Fulbright 2002-06-04 11:25:56 EDT
Jeremy do you know of issues with the dpt controller?
Comment 3 Jeremy Katz 2002-06-04 11:33:22 EDT
On a 7.2 system, you also need to use the update disk which has been released
for 7.2 as well.
Comment 4 Terry Letsche 2002-06-04 11:38:20 EDT
On 7.2 or 7.3? This is concerning 7.3, which has a module available to load on 
the install media already.
Comment 5 Jeremy Katz 2002-06-04 12:38:14 EDT
To quote what you said -- "This is on RH 7.2 systems built with Tim Calloway's
7.2 boot floppies. I have not tried it on a bare system with DPT SCSI card."

With 7.3, Tom says that he has done an install with the hardware which he has
and that it worked for him without any changes.
Comment 6 Terry Letsche 2002-06-04 12:57:37 EDT
To clarify: This system already has 7.2 on it. I'm trying to upgrade to 7.3.

The _original_ install on this server (7.2) used an update disk from Tom. On 
the upgrade I expected to be able to use the new installer, per Tom, with no 
problem. On reboot after install it can't find the paritions because it doesn't 
have the dpt_i2o in the initrd that is generated.
Comment 7 Jeremy Katz 2002-06-04 14:44:27 EDT
Did your /etc/modules.conf contain the scsi_hostadaptor alias for dpt_i2o?
Comment 8 Terry Letsche 2002-06-05 17:06:30 EDT
No, I run monolithic kernels on my servers. There was a 
leftover /etc/modules.conf from my initial install, and it did not have the 
dpt_iso module listed in it. If having the leftover /etc/modules.conf is the 
cause, would adding the dpt_i2o driver to it make the next install work better?
Comment 9 Jeremy Katz 2002-06-05 17:22:40 EDT
You have to have the scsi adaptor module alias listed in modules.conf, otherwise
mkinitrd has no way to find out that it needs to add the module to the initrd. 
So with it there, yes, an upgrade should work fine.

Note You need to log in before you can comment on or make changes to this bug.