Bug 65570 - named fails with the -u option
Summary: named fails with the -u option
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-27 19:05 UTC by Joe Acosta
Modified: 2007-04-18 16:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-06 19:16:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Acosta 2002-05-27 19:05:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510

Description of problem:
I try to run named -u nobody and it fails

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. try running named on RH 7.3 as any user other than root and it fails
2. named -u nobody
3. ps -ef |grep named
4. nothing
5. named 
6. ps -ef |grep named 
7, you'll see named process running as root 
	

Additional info:

Comment 1 Joe Acosta 2002-10-24 18:57:40 UTC
This is on a machine that was upgraded from 7.2 and the 7.2 machine was not
running named.  After installing 7.3 I decided to setup a caching nameserver and
am forced to run as root.  This is not desirable.

Comment 2 bradley 2002-11-12 21:51:23 UTC
This problem represents itself when applying the errata bind packages to version
9.2.1.  named complains that the -u option is not availble until kernel
2.3.something

Comment 3 bradley 2002-11-12 21:51:43 UTC
This problem represents itself when applying the errata bind packages to version
9.2.1.  named complains that the -u option is not availble until kernel
2.3.something

Comment 4 Daniel Walsh 2003-01-06 19:16:27 UTC
So this is not a bug correct?

Comment 5 Joe Acosta 2003-01-07 03:04:04 UTC
kernle 2.3?  What?  This was a RH box that was upgraded from 7.1 to 7.2 to 7.3
and in 7.3 I tried to setup named and it did not work.

Something in the 7.1 to 7.3 upgrade and erratas that were applied completely
gacked my 7.3 system.  

I ultimately had to reinstall 7.3 from scratch and this went away.  


Note You need to log in before you can comment on or make changes to this bug.