Bug 65574 - add a group using redhat-config-users and see multiple entries
add a group using redhat-config-users and see multiple entries
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: libuser (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-27 16:09 EDT by Joe Acosta
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 08:45:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe Acosta 2002-05-27 16:09:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510

Description of problem:
I added a few groups through linuxconf and other tools and now
redhat-config-users (could the name be any longer? why not rh-userconf?)
shows multiple entries fro ident and nobody groups. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. add a new group 
2. I choose nobody
3. see multiple entries
4. delete teh first entry 
5. it may still be there
	

Actual Results:  multiple entries show in the configuration tool, but only
single entries are in the /etc/group file. This is just weird and ugly.

Additional info:
Comment 1 Joe Acosta 2002-05-27 16:20:36 EDT
hit the refresh button and it seems to go away.  Maybe a fix could be to exectue
the code of refresh after adding a group
Comment 2 Brent Fox 2002-05-28 12:36:16 EDT
Just curious, did you do an upgrade from a previous version of Red Hat Linux or
was this a clean install?  I cannot reproduce the error on a clean install, but
I do see the behavior on a laptop that I did an upgrade on...
Comment 3 Joe Acosta 2002-05-28 20:55:56 EDT
Yes this was an upgraded machine.  It weas originally RH 7.1 then upgraded to
7.2 and now 7.3.  This is the first time I used this tool.
Comment 4 Brent Fox 2002-06-01 10:54:13 EDT
nalin, does this look like a libuser bug to you?  I can reproduce it on my
laptop, which was an upgrade.  When run from the command line, I get lots of
stuff that looks like:


** (redhat-config-users.py:4936): CRITICAL **: file user.c: line 195
(extract_id): assertion `array != NULL' failed

** (redhat-config-users.py:4936): CRITICAL **: file user.c: line 1046
(lu_dispatch): assertion `ldata != INVALID' failed

** (redhat-config-users.py:4936): CRITICAL **: file user.c: line 195
(extract_id): assertion `array != NULL' failed

** (redhat-config-users.py:4936): CRITICAL **: file user.c: line 1046
(lu_dispatch): assertion `ldata != INVALID' failed

** (redhat-config-users.py:4936): CRITICAL **: file user.c: line 195
(extract_id): assertion `array != NULL' failed

** (redhat-config-users.py:4936): CRITICAL **: file user.c: line 1046
(lu_dispatch): assertion `ldata != INVALID' failed

** (redhat-config-users.py:4936): CRITICAL **: file user.c: line 195
(extract_id): assertion `array != NULL' failed

** (redhat-config-users.py:4936): CRITICAL **: file user.c: line 1046
(lu_dispatch): assertion `ldata != INVALID' failed

** (redhat-config-users.py:4936): CRITICAL **: file user.c: line 195
(extract_id): assertion `array != NULL' failed

** (redhat-config-users.py:4936): CRITICAL **: file user.c: line 1046
(lu_dispatch): assertion `ldata != INVALID' failed

** (redhat-config-users.py:4936): CRITICAL **: file user.c: line 195
(extract_id): assertion `array != NULL' failed

** (redhat-config-users.py:4936): CRITICAL **: file user.c: line 1046
(lu_dispatch): assertion `ldata != INVALID' failed
Comment 5 Robert P. J. Day 2002-06-08 07:59:32 EDT
  i'm getting exactly these error messages (same line numbers, 195 and 1046)
after i run redhat-config-users from the command line.  you can generate
more of them by pressing the "Apply filter" button.

  this is on a fresh install of 7.3, not an upgrade.
Comment 6 Miloslav Trmač 2004-08-31 08:45:28 EDT
I can't reproduce this with a recent libuser and system-config-users;
system-config-users doesn't even allow adding a "nobody" group because
it already exists.

If any of the described behaviors still happen with a recent
libuser version, please reopen the bug and attach specific information
how to reproduce it.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.