Bug 65591 - Unhandled exception occured while upgrading from 7.1 to 7.2
Unhandled exception occured while upgrading from 7.1 to 7.2
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
7.2
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Florian La Roche
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-28 05:17 EDT by Gilles Corsini
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-18 13:46:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
produced while upgrading error occured (44.26 KB, text/plain)
2002-05-28 05:19 EDT, Gilles Corsini
no flags Details

  None (edit)
Description Gilles Corsini 2002-05-28 05:17:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
With upgrade pack (7.1 to 7.2), booting from CD1 is OK. Been asked for 
language, keyboard, mouse and for partition migration to new filesystem. After 
a screen proposing the new GRUB multiboot system, it gives out a strange 
message:
An unhandled exception has occured. This is most likely a bug. Please copy the 
full text of this exception...and send a bug report against anaconda to 
bugzilla !!!
I tried many combinations, but all produced the SAME (bad) result!

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Boot from upgrade pack CD1
2.Setup language (any), keyboard (tried with US, SG and GE)
3.Let automatic package selection (same with manual selection)
4.Migration to new filesystem: irrelevant
5.GRUB/LILO/No boot setup will be irrelevant
6.After begining to copy files, unhandled exception occurs
	

Actual Results:  Error message box (to save to floppy). After click on OK, CD 
is ejected and system restored to reboot.
The error message begins like this (full text in attachement):
Traceback (innermost last):
  File "/usr/bin/anaconda", line 620, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 350, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 778, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()


Expected Results:  Should upgrade correctly!

Additional info:

Tried on 2 different hard disks (MAXTOR 1.8GB and WESTERN 2.1GB) with minimal 
Linux RH 7.1 workstation (both bootable and OK).
Tried on 2 different HW, but both with AMD CPUs (250 and 450MHz).
Both machines have different CD-drive models.
Comment 1 Gilles Corsini 2002-05-28 05:19:09 EDT
Created attachment 58725 [details]
produced while upgrading error occured
Comment 2 Michael Fulbright 2002-05-29 12:56:04 EDT
Is this the Upgrade Pack sold in Europe?
Comment 3 Gilles Corsini 2002-05-30 02:37:10 EDT
Yes, this package has been bought in Switzerland (28th of May 2002).
Comment 4 Michael Fulbright 2002-06-12 12:53:49 EDT
Florian can you assist in this issue, I am not familiar with the upgrade pack
product.
Comment 5 Florian La Roche 2002-11-03 15:18:49 EST
This was a problem updating from i586 kernels AFAIK, but this issue must be
handeled by support as this cannot be fixed via updates.

greetings,

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.