Bug 65596 - DataDirector doesn't probe all luns
DataDirector doesn't probe all luns
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-28 09:10 EDT by Ben Woodard
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-28 09:14:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Woodard 2002-05-28 09:10:52 EDT
Description of Problem:
Evidently, the SCSI subsystem doesn't probe all of the luns for a particular
SCSI chain because if it did so on some hardware it would cause problems. So
there is a white list of cards which have been tested to allow all their luns to
be probed. We have a very high end card here which has been carefully tested and
 which does allow all the luns to be probed. We would like it added to the
white-list.


Version-Release number of selected component (if applicable): 2.4.18-3


How Reproducible: 100%

Here is a very simple one line patch which addes it:

--- scsi_scan.old	Fri May 24 15:05:47 2002
+++ scsi_scan.c	Fri May 24 15:01:57 2002
@@ -160,6 +160,7 @@
 	{"SONY", "TSL",       "*", BLIST_FORCELUN},  // DDS3 & DDS4 autoloaders
 	{"DELL", "PERCRAID", "*", BLIST_FORCELUN},
 	{"HP", "NetRAID-4M", "*", BLIST_FORCELUN},
+
{"DDN", "SAN DataDirector", "*", BLIST_SPARSELUN},

 	/*
 	 * Must be at end of list...
Comment 1 Arjan van de Ven 2002-05-28 09:14:27 EDT
Added; I assume the SPARSELUN flag is tested and that FORCELUN was not enough

Note You need to log in before you can comment on or make changes to this bug.