Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 656161 - [abrt] evince-2.32.0-1.fc14: __strcasestr_sse2: Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
Summary: [abrt] evince-2.32.0-1.fc14: __strcasestr_sse2: Process /usr/bin/evince was k...
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: evince
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Marek Kašík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:71a561400028aab089f6c356825...
: 656163 656169 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-23 06:31 UTC by Need Real Name
Modified: 2010-11-23 08:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-23 08:55:33 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (78.66 KB, text/plain)
2010-11-23 06:31 UTC, Need Real Name
no flags Details
testcase - file causes exception with evince, epdfview & xournal (23.62 KB, application/octet-stream)
2010-11-23 06:51 UTC, Need Real Name
no flags Details

Description Need Real Name 2010-11-23 06:31:09 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: evince /tmp/AlerusRollover.pdf
component: evince
crash_function: __strcasestr_sse2
executable: /usr/bin/evince
kernel: 2.6.35.6-48.fc14.x86_64
package: evince-2.32.0-1.fc14
rating: 3
reason: Process /usr/bin/evince was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1290493831
uid: 500

How to reproduce
-----
1. double-click PDF file
2.
3.

Comment 1 Need Real Name 2010-11-23 06:31:11 UTC
Created attachment 462243 [details]
File: backtrace

Comment 2 Need Real Name 2010-11-23 06:49:17 UTC
*** Bug 656163 has been marked as a duplicate of this bug. ***

Comment 3 Need Real Name 2010-11-23 06:49:32 UTC
*** Bug 656169 has been marked as a duplicate of this bug. ***

Comment 4 Need Real Name 2010-11-23 06:51:23 UTC
Created attachment 462247 [details]
testcase - file causes exception with evince, epdfview & xournal

Comment 5 Michal Schmidt 2010-11-23 08:55:33 UTC
It crashes in the Freetype library, but you are not using the one provided by Fedora.
/usr/lib64/freetype-infinality/libfreetype.so.6.6.1 does not come from a Fedora package.

A quick web search for "freetype-infinality" shows that it is from a 3rd party repo which its author marks as:
  *** THIS IS ALPHA/BETA SOFTWARE.  EXPECT BUGS / CRASHES. ***

Closing. Please reopen if you can reproduce the crash with Fedora packages only.


Note You need to log in before you can comment on or make changes to this bug.