Bug 65628 - vfat option shortname not documented
vfat option shortname not documented
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-28 19:12 EDT by Kjetil T. Homme
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-28 19:53:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjetil T. Homme 2002-05-28 19:12:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
vfat takes the option shortname with possible values lower, win95, winnt  and
winnt.  this is not mentioned in the manual page.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
N/A.


Additional info:
Comment 1 Kjetil T. Homme 2002-05-28 19:53:41 EDT
hmpf.  I tried to attach this file a dozen times, but Bugzilla claimed the file
was empty (could be a Mozilla bug as well).  since it is short, I'll just paste
it in here.

--- orig.mount.8        2002-05-29 01:12:31.000000000 +0200
+++ mount.8     2002-05-29 01:43:44.000000000 +0200
@@ -1481,6 +1481,29 @@
 UTF8 is the filesystem safe 8-bit encoding of Unicode that is used
 by the console. It can be be enabled for the filesystem with this option.
 If `uni_xlate' gets set, UTF8 gets disabled.
+.TP
+.B shortname=
+Defines the behavior for filenames which fit into 8.3.  If a long name
+for a file exists, it will always be preferred for display.  There are four 
+modes:
+.RS
+.TP
+.I lower
+Force the short name to lower case upon display; store a long name when the 
+short name is not all upper case.
+.TP
+.I win95
+Force the short name to upper case upon display; store a long name when the 
+short name is not all upper case.
+.TP
+.I winnt
+Display the short name as is; store a long name when the short name is
+not all lower case or all upper case.
+.TP
+.I mixed
+Display the short name as is; store a long name when the short name is not all
+upper case.
+.RE
 
 .SH "Mount options for xenix"
 None.
Comment 2 Elliot Lee 2002-06-20 15:04:45 EDT
applied

Note You need to log in before you can comment on or make changes to this bug.