Bug 65644 - nmbd returns error message
Summary: nmbd returns error message
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-29 12:53 UTC by Michael Colef
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-04 12:39:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Samba configuration and log files as well as network configuration files (13.38 KB, text/plain)
2002-05-29 12:57 UTC, Michael Colef
no flags Details

Description Michael Colef 2002-05-29 12:53:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011126
Netscape6/6.2.1

Description of problem:
I have installed Red Hat Linux 7.3 on my machine and configured Samba 2.2.3a as
 I had it on my Red Hat Linux 7.2 before, when it was working ok. Now I can do
all the tests suggested in the DIAGNOSIS.txt file and pass them but I cannot log
from the Windows 95 or Windows 98 clients. I   could see my Samba server in the
network properties but if I double click on the icon it takes about three
minutes and the machine returns the message that the Computer ( Samba server )
does not exist on the network. If I ping the server from the client, the server
responds. Occasionally nmbd starts working but if I restart the server it stops
again. I duplicated the same behavior on a different machine running RH 7.3. I
am PUZZLED!!! What is wrong? I have attached the tar of all the files used for
configuration on my machine with their respective directory tree.

Any help is highly appreciated.



Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Enter /etc/rc.d/init.d/smb start
2.Check the /var/log/samba/log.nmbd and log.smbd
3.
	

Actual Results:  Samba does not work in 99.99% of the cases.

Additional info:

Comment 1 Michael Colef 2002-05-29 12:57:21 UTC
Created attachment 58824 [details]
Samba configuration and log files as well as network configuration files

Comment 2 Thomas Grote 2002-06-02 07:18:57 UTC
It appears that I have the same problem.

I installed RHL 7.3 completely from scratch, ie. didn't upgrade from RHL 7.2.

When doing the tests described in chapter 9.2 of the "Using Samba" book 
bundled with
samba-swat-2.2.3a-6.rpm, smbd works.  That is, the tests of smbd are positive.
But nmbd isn't working properly (although the daemon process is running),

It appears that the nmbd bug is related to the file 
/var/cache/samba/unexpected.tdb

When doing the nmbdlookup test (section 9.2.6.2 in using samba), e.g.
"nmbdlookup -B pc3 __SAMBA__", I get the following result

querying __SAMBA__ on 127.0.0.1
tdb((null)): tdb_open_ex: could not open file /var/cache/samba/unexpected.tdb: 
No such file or directory
tdb((null)): tdb_open_ex: could not open file /var/cache/samba/unexpected.tdb: 
No such file or directory
tdb((null)): tdb_open_ex: could not open file /var/cache/samba/unexpected.tdb: 
No such file or directory
192.168.1.3 __SAMBA__<00>


[Note: 192.168.1.3 is the IP of my machine, pc3 the hostname ]

Other tests with nmdlookup yield the same error message, too
("could not open file /var/cache/samba/unexpected.tdb:")

So the problem is obviously related to /var/cache/samba/unexpected.tdb

In contrast to RHL 7.3,  I don't get the problem on RHL 7.2    On that machine,
/var/cache/samba/unexpected.tdb is succesfully created by samba.










Comment 3 Thomas Grote 2002-06-02 17:45:53 UTC
I've installed RHL 7.3 another time on the same (test-)machine.

In this attempt nmbd worked properly without nmblookup issuing
the "could not open file /var/cache/samba/unexpected.tdb" error message.





Comment 4 Michael Colef 2002-06-04 12:39:27 UTC
The problem with the /var/cache/samba is that either the directory is not
created or it does not have the proper permissions set up.

I have solved my problem. I upgraded to samba-2.2.4-3 and because I use
encrypted passwords ( guess what, I forgot that I set the shadow passwords
option in the installation of RedHat 7.3 ) I made both my Windows clients use
encrypted passwords as well. Everything works now.


Note You need to log in before you can comment on or make changes to this bug.