Bug 65657 - Monitor Configuration Fails
Monitor Configuration Fails
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: 82779
  Show dependency treegraph
 
Reported: 2002-05-29 12:28 EDT by Gabriel Donnell
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-19 23:05:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Generated during Red Hat 7.3 installation with the builtin monitor. The log file was generated when the system was booted with the external monitor. (10.70 KB, application/octet-stream)
2002-05-30 18:01 EDT, Gabriel Donnell
no flags Details
Generated with Xconfigurator with the external monitor. The log file wasgenerated by Xconfigurator when it attempted to test & start the X server. (10.17 KB, application/octet-stream)
2002-05-30 18:03 EDT, Gabriel Donnell
no flags Details
Generated with Xconfigurator with the external monitor. The log file was generated by Xconfigurator when it attempted to test & start the X server. (10.17 KB, application/octet-stream)
2002-05-30 18:05 EDT, Gabriel Donnell
no flags Details
Generated with Xconfigurator with the external monitor. The log file wasgenerated when the system was booted with the external monitor. (10.06 KB, application/octet-stream)
2002-05-30 18:07 EDT, Gabriel Donnell
no flags Details

  None (edit)
Description Gabriel Donnell 2002-05-29 12:28:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
I installed Red Hat 7.3 on my Dell Inspiron 4000 laptop, and the X
configuration fails when I hook up an external monitor.  This works
perfectly fine with Red Hat 7.2.

I tried this with several different Dell Inspiron 4000 laptops and
monitors which are recognized by Xcofigurator.  Also, I run the X
configuration before and after the installation.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat 7.3 on a Dell Inspiron 4000 with no external
   monitor to confirm that the X configuration works.
2. Shutdown the system.
3. Attach an external monitor.  I tried a Dell M990, Phillips 107s,
   and Cornerstone 1450p.
4. Bootup the system and X session should fail.
5. If automatically prompted, run Xconfigurator.  Otherwise, run it
   manually.
6. Configure the setting which may be detected correctly.
7. Notice that testing and starting the X session fails.
8. Install Red Hat 7.3 on a Dell Inspiron 4000 with the external
   monitor to confirm that the X configuration.

Actual Results:  Testing & Starting the X session hangs & fails.

Expected Results:  Tsting & Starting the X session should complete successfully.

Additional info:

This is very urgent and time critical because it is stopping me from
deploying Red Hat 7.3 to the users.  We have deadlines which were
and will be missed.
Comment 1 Mike A. Harris 2002-05-29 23:48:23 EDT
X is configured for whatever display is powered on.  If you want an
external display configured, then you must run Xconfigurator while
that display is powered on, and active.  Xconfigurator does not currently
support configuring multiple monitors either for dualhead nor for switching
between.

Autoconfiguration info is obtained via a DDC probe of the monitor Xconfigurator
is running on currently.  The EDID data returned is looked up in a Monitor
database and this data is used to configure the display.  If the display does
not work with DDC, then manual monitor selection from the list is required, or
manual configuration of each setting is needed.

Please attach your X server log and config so I can verify wether or not
the monitor is in the database.
Comment 2 Gabriel Donnell 2002-05-30 18:01:20 EDT
Created attachment 59024 [details]
Generated during Red Hat 7.3 installation with the builtin monitor.  The log file was generated when the system was booted with the external monitor.
Comment 3 Gabriel Donnell 2002-05-30 18:03:55 EDT
Created attachment 59025 [details]
Generated with Xconfigurator with the external monitor.  The log file wasgenerated by Xconfigurator when it attempted to test & start the X server.
Comment 4 Gabriel Donnell 2002-05-30 18:05:50 EDT
Created attachment 59026 [details]
Generated with Xconfigurator with the external monitor.  The log file was generated by Xconfigurator when it attempted to test & start the X server.
Comment 5 Gabriel Donnell 2002-05-30 18:07:18 EDT
Created attachment 59027 [details]
Generated with Xconfigurator with the external monitor.  The log file wasgenerated when the system was booted with the external monitor.
Comment 6 Gabriel Donnell 2002-05-30 18:09:24 EDT
Hello mharris@redhat.com & dkl@redhat.com,

You slightly misunderstood my issue.  I do not want to use the laptop builtin
and external monitors simultaneously.  I only want to use the external monitor
by itself with the builtin monitor off (closed).

The X configuration and session work fine with the laptop builtin monitor.
The problem is that when I connect a monitor to the port on the laptop or 
docking station (Advanced Port Replicator (APR)), the X session hangs.  When I
run Xconfigurator to change the parameters, it fails when it tries to test and
start the X session.

I reviewed some other Xconfigurator & XFree86 bug reports.  I noticed that the
problem has existed for a while with Red Hat 7.x.  Also, the problem has been
reported for several ATI video cards that are provided with Dell laptops.

Below are the specifications for my system:
- System: Dell Inspiron 4000 Laptop
- Video:
  - Manufacture: ATI
  - Type (Dell): ATI Mobility M3
  - Type (Windows): ATI Rage Mobility 128
  - Memory: 8MB
- Monitor:
  - Internal:
    - Manufacture: Dell
    - Type: XGA, active-matrix color (TFT)
    - Resolution: 1024x768
  - External:
    - Manufacture: Cornerstone
    - Type: p1450
    - Resolution: 1600x1200

I installed Red Hat Linux 7.2 on this system and had the same problem.  This
is a correction to my statement in the description when I submitted this
request.

I installed Red Hat Linux 7.2 on a Dell Inspiron 3800 with an ATI Rage P/M
Mobility AGP 2X video card.  It works fine with the laptop builtin and
external monitors.

Attached are three (3) compressed tar files that have XF86Config files and
the corresponding log file.  Below are the descriptions:
- Anaconda.tar.gz
  Generated during Red Hat 7.3 installation with the builtin monitor.  The log
  file was generated when the system was booted with the external monitor.
- Xconfigurator.tar.gz
  Generated with Xconfigurator with the external monitor.  The log file was
  generated by Xconfigurator when it attempted to test & start the X server.
- Docked.tar.gz
  Generated with Xconfigurator with the external monitor.  The log file was
  generated when the system was booted with the external monitor.

This is still very urgent for me.  I am stuck using Macro$hit Windows until
this problem is fixed.  As you can see from the "User-Agent", I had to use
Macro$hit Internet Exlpoder to submit this bug report.  Please help as soon as
possible because I desparately need to use Linux with the external monitor.

Thank,
Gabriel (Gabe) Donnell
Comment 7 Gabriel Donnell 2002-05-30 18:11:34 EDT
Hello,

I accidentally added the Xconfigurator.tar.gz attachment twice.  Please ignore
one of them.

Sorry,
Gabriel (Gabe) Donnell
Comment 8 Mike A. Harris 2004-04-19 23:05:20 EDT
Red Hat Linux 7.x is no longer supported by Red Hat.  Xconfigurator
has been replaced by redhat-config-display in Red Hat Linux 8.0, 9,
Red Hat Enterprise Linux 3, and Fedora Core 1, which has recently
been replaced by system-config-display in our current development.

If there are similar issues in our currently supported operating
system products, please feel free to file a new bug report against
the system-config-display or redhat-config-xfree86 components
respectively, and we will try to address them in future releases.

Thanks in advance.

Closing "WONTFIX" due to product no longer being supported, and
Xconfigurator being obsoleted.

Note You need to log in before you can comment on or make changes to this bug.