Bug 65680 - man is looking for man.config in /usr/etc instead of /etc
Summary: man is looking for man.config in /usr/etc instead of /etc
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: wdovlrrw
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-29 22:37 UTC by Need Real Name
Modified: 2007-04-18 16:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-31 15:34:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-05-29 22:37:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
man seems to be looking for man.config in /usr/etc, while it is actually
installed in /etc. So, if you don't have a MANPATH, you don't get man pages. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
For example, run 'strace man'. You will see that it tries this:

open("/usr//etc/man.config", O_RDONLY)  = -1 ENOENT (No such file or directory)

	

Expected Results:  open("/etc/man.config", O_RDONLY)



Additional info:

Comment 1 Bernhard Rosenkraenzer 2002-07-31 15:34:19 UTC
This was fixed some time between 7.3 and man 1.5j-9

Comment 2 Joe Orton 2002-12-10 21:24:16 UTC
Confirmed fixed in 8.0, man-1.5j-11:

open("/usr//etc/man.config", O_RDONLY)  = -1 ENOENT (No such file or directory)
open("/etc/man.conf", O_RDONLY)         = -1 ENOENT (No such file or directory)
open("/etc/man.config", O_RDONLY)       = 3

and "export -n MANPATH; man ls" works fine now.


Note You need to log in before you can comment on or make changes to this bug.