This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 65705 - initrd disabled on BOOT Kernel during pxe load but not floppy load
initrd disabled on BOOT Kernel during pxe load but not floppy load
Status: CLOSED DUPLICATE of bug 63945
Product: Red Hat Linux
Classification: Retired
Component: pxe (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-30 11:52 EDT by Greg Caetano
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-03 14:54:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Caetano 2002-05-30 11:52:21 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (Windows NT 5.0; U)

Description of problem:
When using the BOOTNET floppy image in a system with physically more than 900MB of memory, the BOOT kernel displays an error message but 
continues to boot and allow the OS to be installed. When using the same VMLINUZ and INITRD.IMG delivered via PXE/TFTP on the same physical 
box the Kernel prints a message that the initrd extends beyond end of memory and disables initrd, therefore not allowing root to be mounted and 
installation halts with a Panic

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
	

Additional info:

boot log from bootnet floppy boot:

BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000003fffc000 (usable)
 BIOS-e820: 000000003fffc000 - 0000000040000000 (ACPI data)
 BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee10000 (reserved)
 BIOS-e820: 00000000ffc00000 - 0000000100000000 (reserved)
Warning only 896MB will be used.
Use a HIGHMEM enabled kernel.
On node 0 totalpages: 229376
zone(0): 4096 pages.
zone(1): 225280 pages.
zone(2): 0 pages.
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
Kernel command line: ks initrd=initrd.img lang= devfs=nomount ramdisk_size=7168 BOOT_IMAGE=vmlinuz console=ttyS0,115200 text
Initializing CPU#0
Detected 692.109 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 1379.53 BogoMIPS
Memory: 897284k/917504k available (1114k kernel code, 17756k reserved, 89k data, 104k init, 0k highmem)
etc......


boot log from pxe/tftp loaded kernel/initrd:
UD 206.183.137.90 .      
Downloading Linux kernel image...
UD 206.183.137.90 
Downloading initrd image...
Linux version 2.4.18-3BOOT (bhcompile@stripples.devel.redhat.com) (gcc version 2.96 20000731 (Red Hat Linux 7.3
2.96-110)) #1 Thu Apr 18 06:53:28 EDT 2002
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009fc00 (usable)
 BIOS-e820: 000000000009fc00 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000003fffc000 (usable)
 BIOS-e820: 000000003fffc000 - 0000000040000000 (ACPI data)
 BIOS-e820: 00000000fec00000 - 00000000fec10000 (reserved)
 BIOS-e820: 00000000fee00000 - 00000000fee10000 (reserved)
 BIOS-e820: 00000000ffc00000 - 0000000100000000 (reserved)
Warning only 896MB will be used.
Use a HIGHMEM enabled kernel.
initrd extends beyond end of memory (0x3ff00000 > 0x38000000)
disabling initrd
On node 0 totalpages: 229376
zone(0): 4096 pages.
zone(1): 225280 pages.
zone(2): 0 pages.
Kernel command line: ks console=ttyS0,115200 ramdisk_size=8192
Local APIC disabled by BIOS -- reenabling.
Found and enabled local APIC!
Initializing CPU#0
Detected 692.133 MHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 1379.53 BogoMIPS
Memory: 903504k/917504k available (1092k kernel code, 13612k reserved, 327k data, 160k init, 0k highmem)
<.....snip out ...>
TCP: Hash tables configured (established 262144 bind 65536)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
cramfs: wrong magic
FAT: bogus logical sector size 0
Kernel panic: VFS: Unable to mount root fs on 01:01
Comment 1 Arjan van de Ven 2002-06-03 14:54:37 EDT
This seems to be a case of "pxe loads the initrd in high memory" again.
The kernel cannot see memory > 900Mb, so it won't find the initrd either.
Comment 2 Elliot Lee 2002-06-21 13:13:38 EDT

*** This bug has been marked as a duplicate of 63945 ***

Note You need to log in before you can comment on or make changes to this bug.