Bug 6571 - shell mode problems, one typeface problem
shell mode problems, one typeface problem
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: emacs (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-31 10:31 EST by hajic
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-17 10:09:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hajic 1999-10-31 10:31:30 EST
The first is a bug (I think), the other three problems are
just annoying since I have to do something (as everybody I
suppose).

Environment: RH 6.1, emacs 20.4, tchs 6.08, all
out-of-the-box:

1) (bug) M-x dirs copies the command name it sends to the
shell ('dirs') to the buffer thus making the emacs' internal
'cd' command wanting to cd to (in general non-existent)
directory 'dirs' instead to the correct one, therefore
saying "couldn't cd" in the minibuffer. Yes I did disable
echo and ^M as suggested in the info & FAQ.

2) (annoying default setting) disabling ^M: could this be
added to the init? I mean

(add-hook 'comint-output-filter-functions
                    'comint-strip-ctrl-m)

3) (annoying default setting) not echoing non-substituted
commands: could this be added to the defaults?

(set-variable 'comint-process-echoes 'T)

4) (annoying) default typeface: it appears it has no idea
what the -fg and -bg colors are from the emacs' command
line, as it sets the dafault typeface colors to black &
white. Therefore one has to do color setting such as
(custom-set-variables)
(custom-set-faces
 '(default ((t (:foreground "white" :background
"firebrick")))))

(if one has set the -fg and -bg colors to firebrick and
white).

-- Jan Hajic
hajic@ufal.mff.cuni.cz
Comment 1 Cristian Gafton 2000-02-17 10:09:59 EST
I find most of these annoying as well, but we should persuade FSF to change
these defaults.

We're getting nasty mail from FSF folks every time we change the defaukts on
emacs, so it might be better to take this feedback directly to them.

Note You need to log in before you can comment on or make changes to this bug.