Bug 65713 - aic7xxx driver fails to load on boot with smp kernels
aic7xxx driver fails to load on boot with smp kernels
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Doug Ledford
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-30 13:53 EDT by Mike
Modified: 2007-04-18 12:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-21 04:59:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike 2002-05-30 13:53:18 EDT
From Bugzilla Helper:

Description of problem:
When using either smp or bigmem kernels, the aicxxx driver won't load.  
Repeated boot messages indicate:
  Kernel Free SCB List: x 1 0 (x seems to change between 2 and 3)
  scsi0:0:1:0:Command already completed
  aic7xxx_abort returns 0x2002 

Machine has both aic7880 and AMI megaraid controllers.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot/reboot
2. select any 2.4.x smp/bigmem/enterprise kernel
3.	

Actual Results:  boot failure

Expected Results:  successful boot as with single processor kernel

Additional info:

Here are the results from single processor kernel for the scsi section:
kernel: SCSI subsystem driver Revision: 1.00
kernel: (scsi0) <Adaptec AIC-7880 Ultra SCSI host adapter> found at PCI 1/11/0
kernel: (scsi0) Wide Channel, SCSI ID=7, 16/255 SCBs
kernel: (scsi0) Downloading sequencer code... 436 instructions downloaded
kernel: (scsi1) <Adaptec AIC-7880 Ultra SCSI host adapter> found at PCI 1/12/0
kernel: (scsi1) Wide Channel, SCSI ID=7, 16/255 SCBs
kernel: (scsi1) Downloading sequencer code... 436 instructions downloaded
kernel: scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.2.4/5.2.0
kernel:        <Adaptec AIC-7880 Ultra SCSI host adapter>
kernel: scsi1 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.2.4/5.2.0
kernel:        <Adaptec AIC-7880 Ultra SCSI host adapter>
kernel: blk: queue f7f77c18, I/O limit 4095Mb (mask 0xffffffff)
kernel:   Vendor: QUANTUM   Model: DLT7000           Rev: 1E48
kernel:   Type:   Sequential-Access                  ANSI SCSI revision: 02
kernel: blk: queue f77d3a18, I/O limit 4095Mb (mask 0xffffffff)
kernel: blk: queue f77d3a18, I/O limit 4095Mb (mask 0xffffffff)
kernel:   Vendor: NEC       Model: CD-ROM DRIVE:464  Rev: 1.05
kernel:   Type:   CD-ROM                             ANSI SCSI revision: 02
kernel: blk: queue f779e618, I/O limit 4095Mb (mask 0xffffffff)
kernel: megaraid: v1.18 (Release Date: Thu Oct 11 15:02:53 EDT 2001)
kernel: megaraid: found 0x101e:0x9010:idx 0:bus 1:slot 10:func 0
kernel: scsi2 : Found a MegaRAID controller at 0xec90, IRQ: 11
kernel: megaraid: [U.84:1.63] detected 1 logical drives
kernel: megaraid: channel[1] is raid.
kernel: megaraid: channel[2] is raid.
kernel: scsi2 : LSI Logic MegaRAID U.84 254 commands 16 targs 5 chans 7 luns
kernel: blk: queue f779e618, I/O limit 4095Mb (mask 0xffffffff)
kernel: scsi2: scanning channel 0 for devices.
kernel:   Vendor: DELL      Model: 6UW BACKPLANE     Rev: 7
kernel:   Type:   Processor                          ANSI SCSI revision: 02
kernel: blk: queue f7338618, I/O limit 4095Mb (mask 0xffffffff)
kernel: scsi2: scanning channel 1 for devices.
kernel: scsi2: scanning virtual channel 1 for logical drives.
kernel:   Vendor: MegaRAID  Model: LD0 RAID5 42840R  Rev: U.84
kernel:   Type:   Direct-Access                      ANSI SCSI revision: 02
kernel: blk: queue f7302618, I/O limit 4095Mb (mask 0xffffffff)
kernel: scsi2: scanning virtual channel 2 for logical drives.
kernel: scsi2: scanning virtual channel 3 for logical drives.
kernel: scsi2: scanning virtual channel 4 for logical drives.
kernel: Attached scsi disk sda at scsi2, channel 2, id 0, lun 0
kernel: SCSI device sda: 87736320 512-byte hdwr sectors (44921 MB)
Comment 1 Need Real Name 2002-06-21 04:59:12 EDT
This also happens when trying to use 'linux rescue' from the installation disk.
 It dosen't seem to be because of the smp kernel, otherwise the installation and
rescue mode would not fail, would they?  I'm using an L440GX+ intel motherboard
with onboard SCSI.  In order to install, I must use the 'linux no probe' feature
from the installation CD.  Every other method fails because of this problem.  My
boot messages are similar to this bug report.  Every lun is being probed
one-by-one.  Is there any way to stop the aic7xxx module from being loaded
during the CD boot?  Or, can't there be a scsi kernel for installation?  I need
the rescue mode to replace GRUB in case it fails (this is a dual boot system). 
(I used Slackware before, and had no problems with this.  I am swithcing to
RedHat for its ease of maintainance (ironic, huh?).  Days of my life are passing
by, do you have a quick fix for this?).
Comment 2 Doug Ledford 2002-06-26 16:50:38 EDT
These are two different problems.

mleonard:

Your problem is interrupt routing in SMP mode is not working.  You need to boot
the SMP kernel with the option noapic in order to get working interrupts again
(at least that should work).  You can also try going into the machine's BIOS and
checking the setting for the MP table version.  It should be either 1.1 or 1.4.
 Changing it from whatever it is to the other *might* allow the SMP kernel to
work without the noapic option.  Either way, this is a hardware problem and one
of those two things should work around it for you, but there isn't anything to
be done in software.

khalilw:

Your problem is the (very well) documented L440GX bug.  It's an Intel problem. 
The best we can do is to have you follow the instructions that have been on my
personal web page for over a year now.  Go to people.redhat.com/dledford and
click on the 440GX link.  Follow those directions explicitly!  You must do all
the things they tell you to do if you want your machine to work!
Comment 3 Mike 2002-06-28 14:22:28 EDT
Changing the BIOS settings didn't work, but the noapic option did (with the 
original BIOS settings-MP1.4).

I'm begining to wonder if I posted this in the wrong area.

I've been having the same problem since trying to upgrade from RH7->RH7.2. 
Since one of the biggest changes was the 2.2x to 2.4x kernel, this was where I 
decided to post.

Thanks for your help.
Comment 4 Need Real Name 2002-06-28 23:07:55 EDT
I posted about this on bug #67235, as well, because I believe this is a problem
with the installation disk.  Upgrading from kernel 2.4.18-3smp to 2.4.18-5smp
seems to have solved my problems, but of course I can't use the 'rescue' disk.

Note You need to log in before you can comment on or make changes to this bug.