Bug 657132 - [RFE] Handling for multiple config files in brew
Summary: [RFE] Handling for multiple config files in brew
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Publican
Classification: Community
Component: Publican Users Guide
Version: 2.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Ruediger Landmann
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-25 01:55 UTC by Laura Bailey
Modified: 2013-01-25 01:55 UTC (History)
3 users (show)

Fixed In Version: 3.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-23 10:32:56 UTC


Attachments (Terms of Use)

Description Laura Bailey 2010-11-25 01:55:03 UTC
I'm using the conditional attribute to build two very similar books with a few unique sections, without having to maintain two totally separate document sets. The problem is, this means I have to change the condition value in the publican.cfg file each time I build.

jfearn: the problem you are going to hit is that it uses Book_Info for the details, or the cfg file, and AIUI we don't handle multiple config files in packaging
laubai: it will just mean that I need to edit the publican.cfg file every time we go to build
laubai: if we could set the condition as part of the command line that would be useful, though 
laubai: is there any way to do that, do you think?
jfearn: no, I'd do it with a second config file, but make sure we pass the config file in to the packaging

Comment 1 Fedora Admin XMLRPC Client 2010-12-08 01:02:01 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Jeff Fearn 🐞 2010-12-08 23:33:31 UTC
Actually I think this already works, because the publican.cfg file used in the SRPM is written at packaging time by publican.

It probably needs to be documented in the PUG though.

Comment 3 Ruediger Landmann 2011-07-14 05:39:34 UTC
Confirmed that the nominated alternative config file is used to generate the publican.cfg file that gets packaged.

Advice added to "3.8. Conditional tagging" in the PUG:

If you maintain two versions of a book in the same repository, we recommend using a separate config file for each version. For example, the upstream.cfg file might contain the condition condition: upstream and the enterprise.cfg file might contain the condition condition: enterprise. You could then specify the version of the document to build or package with the --config; for example, publican package --lang en-US --config upstream.cfg. Using two separate config files saves you from having to edit the one config file each time you build or package a document. 

Committed revision 1831.

Comment 4 Tomas Capek 2012-04-25 16:22:46 UTC
Verified that the advice can be found in the Conditionaltagging.xml file in the PUG.


Note You need to log in before you can comment on or make changes to this bug.