Bug 65752 - impossible to reach final update summary screen using GUI
impossible to reach final update summary screen using GUI
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2002-05-31 05:23 EDT by colin redfern
Modified: 2015-01-07 18:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-02-14 10:39:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description colin redfern 2002-05-31 05:23:44 EDT
Description of Problem:
user cannot proceed to completion of a GUI driven update

Version-Release number of selected component (if applicable):
latest version installed by up2date.

version number not available from gui OR command line (is this not a bug also?)

How Reproducible:

Steps to Reproduce:
1. run up2date
2. select a package to update
3. observe error message generated

Actual Results:

the "next" button remains greyed out after the installation has completed.

here is the error text generated 

[root@bob root]# up2date
Traceback (innermost last):
  File "/usr/share/rhn/up2date_client/gui.py", line 832, in doInstallation
AttributeError: setArrorCursor

the user must press "cancel" to be able to continue

Expected Results:
the "next" button should be un greyed

Additional Information:
despite this warning. the installation appears to have proceeded correctly.
Comment 1 Adrian Likins 2002-06-13 16:20:15 EDT
what version of the client is this?
Comment 2 colin redfern 2002-06-13 18:44:45 EDT
[root@bob root]# rpm -q up2date

Comment 3 Need Real Name 2002-07-31 13:56:07 EDT
I get this same thing. Two of my last three updates have crashed with the exact
error the reporter gives after installation is 100%. I have to ^C up2date and I
worry it may be doing Bad Things to my RPM db.

up2date-2.7.61-7.x.2  (Red Hat 7.2)

This never happened before... I've done up2date every day an update was
available since 7.2 was released. There were new up2date packages some time
ago... eaither that, or some different network input for an enhanced client in 7.3?
Comment 4 colin redfern 2002-08-01 05:51:32 EDT
I just got this exact same error on another machine.
on a completely fresh RH7.2 install
I ran up2date for the first time and updated only some selected essentials from
the available list.
Those that i can remember were all assosciated with up2date and libc/glibc

the next day I run up2date and get the error.
once again

$rpm -q up2date
Comment 5 Adrian Likins 2003-01-20 18:27:15 EST
ugh, yeah. Fixed in all current code bases. I belive this fix has
made it into all errata as well (2.8.39 for that platform)
Comment 6 Jay Turner 2003-02-14 10:39:24 EST
Fix confirmed with latest released code.

Note You need to log in before you can comment on or make changes to this bug.