Bug 65753 - PDF files produce errors on blank pages in Acrobat version 5.xx
PDF files produce errors on blank pages in Acrobat version 5.xx
Status: CLOSED RAWHIDE
Product: Red Hat Web Site
Classification: Red Hat
Component: Documentation (Show other bugs)
current
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tammy Fox
Tammy Fox
http://www.redhat.com/docs/manuals/li...
: Documentation
: 65754 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-31 06:20 EDT by Nigel Burman
Modified: 2009-08-19 20:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-05 05:51:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Burman 2002-05-31 06:20:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (WinNT; U)

Description of problem:
When opening this pdf in versions of Acrobat later than 5.0 the following errors appear on the blank pages:
"There was an error processing a page".
"The page contents object has the wrong type".
The pdf opens correctly and without any error messages in version 4.xx of Acrobat.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open http://www.redhat.com/docs/manuals/linux/RHL-7.3-Manual/pdf/rhl-ig-x86-en-73.pdf under Windows 2000 using Adobe Acrobat version 5.05.
2. Page down until you hit a blank page.
3. A dialog box appears with the above error messages.
	

Actual Results:  Click OK and then you can continue without further complaints until the next blank page is hit. Cannot print though, due to this problem.

Expected Results:  Blank page should not have produced any errors.

Additional info:

I found the following useful information on:
http://www.ghostscript.com/pipermail/bug-gs/2001-July/000535.html


Suggested fix, if any:
Acrobat Reader 5.0 apparently doesn't like the
"/Contents []" that is
generated for the blank page. One possible fix would
be to not
generate any "/Contents" for a blank page.

I already submitted a question to Adobe's User Forums
asking if this
problem was a bug in Acrobat Reader 5.0. Here is the
reply:

    No, I think the bug is in the PDF file. Acrobat 5
has stricter error
    checking.


    A blank page should have one of the following:


    - no /Contents key
    - Contents key containing an empty stream
    - Contents key containing an array containing an
empty stream


    The Specification is not explicit about
disallowing a zero length
    array, but it does say it must be an array of
streams. An empty
    array has no particular type, so is arguably NOT
an array of
    streams.
Comment 1 Tammy Fox 2002-05-31 15:16:47 EDT
*** Bug 65754 has been marked as a duplicate of this bug. ***
Comment 2 Tammy Fox 2002-05-31 15:32:34 EDT
This for the link. I was not aware of this problem when the PDF file were
produced. I tested them under Acrobat Reader 5.05 under Windows ME, and it
did not give me any errors. I have filed bug #65798 against ghostscript to
see if we can fix this problem. Thanks for the help.
Comment 3 Tammy Fox 2002-05-31 16:04:40 EDT
FWIW, I downloaded Adobe Acrobat 5.05 for Linux, and it opens and prints the PDF
correctly.
Comment 4 Tammy Fox 2002-07-04 18:57:46 EDT
Can someone with Windows 2000 using Adobe Acrobat version 5.05 try to view
http://people.redhat.com/tfox/rhl-cg-en.pdf? I produced it with ghostscript
7.05, which is supposed to fix the problem.
Comment 5 Nigel Burman 2002-07-05 05:50:56 EDT
Tried Adobe Acrobat version 5.05 under Windows 2000 with the pdf at: http://people.redhat.com/tfox/rhl-cg-en.pdf and everything seems to display 
correctly - certainly no error messages from Acrobat.

Ghostscript 7.05 would seem, therefore,  to fix this problem.
Comment 6 Tammy Fox 2002-07-11 17:37:40 EDT
Updated PDFs made with ghostscript 7.05 have been posted to 
http://www.redhat.com/docs/manuals/linux/RHL-7.3-Manual/ and an errata
has been posted to http://www.redhat.com/docs/errata/RHL-7.3-Manual/.

The PDFs include bug fixes as well.
Comment 7 Moris 2003-05-04 21:02:23 EDT
The 7.3 release notes PDF on the RH website / Support Docs still gives those 
errors

Note You need to log in before you can comment on or make changes to this bug.