Bug 65754 - PDF files produce errors on blank pages in Acrobat version 5.xx
PDF files produce errors on blank pages in Acrobat version 5.xx
Status: CLOSED DUPLICATE of bug 65753
Product: Red Hat Web Site
Classification: Red Hat
Component: Documentation (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tammy Fox
Tammy Fox
: Documentation
Depends On:
  Show dependency treegraph
Reported: 2002-05-31 06:20 EDT by Nigel Burman
Modified: 2009-08-19 20:02 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-05-31 06:20:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nigel Burman 2002-05-31 06:20:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (WinNT; U)

Description of problem:
When opening this pdf in versions of Acrobat later than 5.0 the following errors appear on the blank pages:
"There was an error processing a page".
"The page contents object has the wrong type".
The pdf opens correctly and without any error messages in version 4.xx of Acrobat.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Open http://www.redhat.com/docs/manuals/linux/RHL-7.3-Manual/pdf/rhl-ig-x86-en-73.pdf under Windows 2000 using Adobe Acrobat version 5.05.
2. Page down until you hit a blank page.
3. A dialog box appears with the above error messages.

Actual Results:  Click OK and then you can continue without further complaints until the next blank page is hit. Cannot print though, due to this problem.

Expected Results:  Blank page should not have produced any errors.

Additional info:

I found the following useful information on:

Suggested fix, if any:
Acrobat Reader 5.0 apparently doesn't like the
"/Contents []" that is
generated for the blank page. One possible fix would
be to not
generate any "/Contents" for a blank page.

I already submitted a question to Adobe's User Forums
asking if this
problem was a bug in Acrobat Reader 5.0. Here is the

    No, I think the bug is in the PDF file. Acrobat 5
has stricter error

    A blank page should have one of the following:

    - no /Contents key
    - Contents key containing an empty stream
    - Contents key containing an array containing an
empty stream

    The Specification is not explicit about
disallowing a zero length
    array, but it does say it must be an array of
streams. An empty
    array has no particular type, so is arguably NOT
an array of
Comment 1 Tammy Fox 2002-05-31 15:16:54 EDT

*** This bug has been marked as a duplicate of 65753 ***

Note You need to log in before you can comment on or make changes to this bug.