Bug 65755 - problems with RPM database
problems with RPM database
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
www.boleknet.z.pl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-31 07:45 EDT by Paul Osmialowski
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-31 07:45:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Osmialowski 2002-05-31 07:45:17 EDT
Description of Problem:
I'm trying to be up to date with all RedHat Errata patches. Recently, when I was
installing some of them I got strange error. Last packages I did was: tcpdump,
libpcap and arpwatch. I took them from Errata page, and type:
rpm -Fvh *.rpm
After completing job I saw this:
rpmdb: Suspiciously high nelem of 4294967295
error: db4 error(-30979) from db->verify: DB_VERIFY_BAD: Database verification
failed.
The same message I saw when I removed imap package (since I don't need it now):
rpm -e imap
About month ago I upgraded rpm from RedHat Errata page, but I had no problems
with it until now.

Version-Release number of selected component (if applicable):
rpm-4.0.4-7x
db3-3.1.17-7
popt-1.6.4-7x

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Jeff Johnson 2002-05-31 09:54:09 EDT
Yup. Install rpm-4.0.4-7x.18 from Red Hat 7.3, and do
rpm --rebuilddb.

Note You need to log in before you can comment on or make changes to this bug.