This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 657583 - Browser not found when right-clicking Open Link while hovering over a URL
Browser not found when right-clicking Open Link while hovering over a URL
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-26 10:40 EST by Peter H. Jones
Modified: 2010-11-30 11:48 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-30 11:48:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter H. Jones 2010-11-26 10:40:07 EST
Description of problem:
Open Link feature doesn't work in Gnome-Terminal.

Version-Release number of selected component (if applicable):
gnome-terminal-2.32.0-1.fc14.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Display a URL, as in echo http://download.fedora.redhat.com
2. Hover over the URL.
3. Underline appears.
4. Right-click on Open Link.
  
Actual results:
Get a popup window containing:
Could not open the address "http://download.fedora.redhat.com
and
Failed to execute child process "/usr/lib/firefox-3.6/firefox" (No such file or directory)

Expected results:
Firefox should launch with indicated URL

Additional info:

As in bug 431369, I did the following:

gconftool-2 -R /desktop/gnome/applications
 /desktop/gnome/applications/media:
  exec = totem
  exec_arg = 
 /desktop/gnome/applications/component_viewer:
  exec = nautilus %s
 /desktop/gnome/applications/window_manager:
  default = (no value set)
  current = (no value set)
  number_of_workspaces = (no value set)
  workspace_names = (no value set)
 /desktop/gnome/applications/calendar:
  exec = evolution
  needs_term = false
 /desktop/gnome/applications/tasks:
  exec = evolution
  needs_term = false
 /desktop/gnome/applications/at:
  screen_magnifier_enabled = false
  screen_keyboard_enabled = false
  screen_reader_enabled = false
  /desktop/gnome/applications/at/mobility:
   startup = false
   exec = dasher
  /desktop/gnome/applications/at/visual:
   startup = false
   exec = orca -e magnifier
 /desktop/gnome/applications/terminal:
  exec = gnome-terminal
  exec_arg = -x
 /desktop/gnome/applications/browser:
  nremote = true
  exec = firefox
  needs_term = false

Note also that "whereis firefox" gives:
"firefox: /usr/bin/firefox /usr/share/man/man1/firefox.1.gz" , and
not the "/usr/lib/firefox-3.6/firefox" location in the popup. Where
is gnome-terminal getting this incorrect location?
Comment 1 Peter H. Jones 2010-11-30 11:48:48 EST
Fixed it!

Created a new user. Works fine.

In my account with the problem, I used Gconf editor and copied the settings
from the new account. Specifically, I set the keys
/desktop/gnome/url-handlers/http/command
and 
/desktop/gnome/url-handlers/http/command
to contain
firefox "%s"

Works fine now.

Closing as WORKSFORME because I'm wondering if the corruption
occurred as a result of a recent Firefox update.

Note You need to log in before you can comment on or make changes to this bug.