Bug 657594 - rpmdev-setuptree creates ~/.rpmmacro that forces check-rpaths to be run on every file in every rpm build
Summary: rpmdev-setuptree creates ~/.rpmmacro that forces check-rpaths to be run on ev...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmdevtools
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-26 17:46 UTC by Tim Kersten
Modified: 2011-02-06 14:40 UTC (History)
2 users (show)

Fixed In Version: 8.0-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-06 14:40:41 UTC
Type: ---


Attachments (Terms of Use)

Description Tim Kersten 2010-11-26 17:46:57 UTC
Description of problem:
Running rpmdev-setuptree creates a ~/.rpmmacro that contains:
%__arch_install_post /usr/lib/rpm/check-rpaths   /usr/lib/rpm/check-buildroot
There is no need for this to run when the BuildArch of the rpm is set to noarch. Running it causes a significant increase in build time for packages with many files.

Version-Release number of selected component (if applicable):
7.10

How reproducible:
Everytime.

Steps to Reproduce:
1. run: rpmdev-setuptree

  
Actual results:
Outputs ~/.rpmmacros containing:
%__arch_install_post /usr/lib/rpm/check-rpaths   /usr/lib/rpm/check-buildroot

Expected results:
To output ~/.rpmmacros containing:
%__arch_install_post \
  [ "${buildarch}" = "noarch" ] || /usr/lib/rpm/check-rpaths   /usr/lib/rpm/check-buildroot

Comment 1 Ville Skyttä 2010-11-29 19:27:19 UTC
Done slightly differently in git, as there are some rare legitimate cases where a noarch package may ship binaries that would benefit from RPATH checks:
https://fedorahosted.org/rpmdevtools/changeset/6fe4b6e

Panu, could the deprecation warning be removed from check-rpaths' $QA_SKIP_RPATHS test?  I don't want to inflict the warning on each build, and setting $QA_RPATHS isn't suitable because it won't prevent the "find" and check-rpaths-worker from running so I need to control it in rpmdevtools generated macros which is uglier than it needs to be...


Note You need to log in before you can comment on or make changes to this bug.