Bug 657651 - udev-164-5.fc15 whines during an update
udev-164-5.fc15 whines during an update
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-26 20:05 EST by Michal Jaegermann
Modified: 2010-12-06 04:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-06 04:57:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2010-11-26 20:05:22 EST
Description of problem:

Updating udev in rawhide effects the following:
....
  Updating       : udev-164-5.fc15.x86_64                                   6/161 
/var/tmp/rpm-tmp.B4KK0z: line 14: kill: (373) - No such process
.....

That line number strongly suggest that the following loop from preinstall scriptlet is responsible:

    while [ -n "$pid" ]; do
            for p in $pid; do
                    kill $hard $p;
            done
            pid=$(/sbin/pidof -c udevd)
            hard="-9"
    done

Smells like a race with /sbin/pidof still seeing udevd after the first 'kill' because udevd takes some time to cleanly terminate.

If we do not care then why not to do '... done >/dev/null 2>&1' and shut this up? Another option is to wait a bit before the "pidof" check.

Version-Release number of selected component (if applicable):
udev-164-5.fc15
Comment 1 Michal Jaegermann 2010-12-03 13:49:29 EST
The same "No such process" happened when updating to udev-153-5.fc13.x86_64, with line 17 this time, on one machine but not on another one. Again, /sbin/pidof runs too quickly after kill.

Note You need to log in before you can comment on or make changes to this bug.