Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 657946 - Resizing a JWindow in java run with -Dsun.java2d.opengl=True causes a crash
Summary: Resizing a JWindow in java run with -Dsun.java2d.opengl=True causes a crash
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Omair Majid
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9a3b229e9770b2d1609a1654360...
: 655942 675982 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-28 21:07 UTC by Joel Uckelman
Modified: 2012-06-08 20:10 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-08 20:10:43 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (54.60 KB, text/plain)
2010-11-28 21:07 UTC, Joel Uckelman
no flags Details

Description Joel Uckelman 2010-11-28 21:07:49 UTC
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: java -classpath classes:lib/* -Dswing.defaultlaf=com.sun.java.swing.plaf.gtk.GTKLookAndFeel -Dsun.java2d.opengl=True VASSAL.launch.ModuleManager
component: java-1.6.0-openjdk
crash_function: os::abort
executable: /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java
kernel: 2.6.35.6-48.fc14.x86_64
package: java-1.6.0-openjdk-1:1.6.0.0-44.1.9.1.fc14
rating: 4
reason: Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
release: Fedora release 14 (Laughlin)
time: 1290977611
uid: 500

How to reproduce
-----
1. Started VASSAL. (obtainable from http://www.vasssalengine.org).

Comment 1 Joel Uckelman 2010-11-28 21:07:53 UTC
Created attachment 463375 [details]
File: backtrace

Comment 2 Joel Uckelman 2010-11-28 21:15:14 UTC
This appears to be triggered by resizing a JFileChooser.

Comment 3 Joel Uckelman 2010-11-29 17:25:50 UTC
Package: java-1.6.0-openjdk-1:1.6.0.0-44.1.9.1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Started VASSAL. (obtainable from http://www.vasssalengine.org).
2. Resize any window.

Comment 4 Joel Uckelman 2010-11-29 17:29:21 UTC
It appears to be the command line option "-Dsun.java2d.opengl=True" which triggers the crash. Without this option, java doesn't crash.

Comment 5 Joel Uckelman 2010-11-29 17:42:50 UTC
I can reproduce this problem by resizing any JWindow in any program, so long as the program is run with "-Dsun.java2d.opengl=True". Pretty severe bug.

Comment 6 Omair Majid 2010-12-02 19:29:40 UTC
*** Bug 655942 has been marked as a duplicate of this bug. ***

Comment 7 Omair Majid 2010-12-02 19:33:35 UTC
Unfortunately, I can not reproduce this problem on my current machine as the java2d opengl pipeline wont start. I will try to find another way of reproducing this problem.

On the surface though, it may be that the opengl pipeline does not install X error handlers that the standard x11 pipeline installs. We did observe crash-on-resizing with the x11 pipeline before.

Comment 8 Joel Uckelman 2010-12-03 10:40:14 UTC
This crash didn't happen in whatever the last version of OpenJDK was that shipped with F13---that might help track down what changes are at fault.

Comment 9 Omair Majid 2011-01-15 00:03:07 UTC
Thanks for the tip; F13 is using IcedTea6 1.8.X, while F14/rawhide is on IcedTea6 1.9.X.

Unfortunately, I cant reproduce this using kvm either; I am getting hit by bug 575825 :/

Comment 10 abrt-bot 2012-03-20 18:07:37 UTC
*** Bug 675982 has been marked as a duplicate of this bug. ***

Comment 11 Joel Uckelman 2012-03-26 19:19:12 UTC
I can no longer reproduce this with java-1.6.0-openjdk-1.6.0.0-65.1.11.1.fc16.x86_64.


Note You need to log in before you can comment on or make changes to this bug.