Bug 65798 - produces PDFs that Acrobat Reader 5.05 can't read properly
produces PDFs that Acrobat Reader 5.05 can't read properly
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: ghostscript (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-31 15:27 EDT by Tammy Fox
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-05 02:03:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tammy Fox 2002-05-31 15:27:29 EDT
I am using the following command to produce a PDF from a PS file:

gs -q -dNOPAUSE -dBATCH -sDEVICE=pdfwrite -sPAPERSIZE=a5 \
-sOutputFile=foo.pdf foo.ps

Some people have said that they can't read the PDF under Windows 2000
using Acrobat Reader 5.05 (#65753). The link given in the other bug:
http://www.ghostscript.com/pipermail/bug-gs/2001-July/000535.html
suggests that ghostscript should not write /Content for blank pages.

Would this fix the problem? The funny thing is that I tried to open
the PDF files in Acrobat Reader 5.05 in Windows ME, and I didn't get
the error messages.
Comment 1 Tammy Fox 2002-05-31 16:05:36 EDT
FWIW, I downloaded Adobe Acrobat Reader 5.05 for Linux, and it opens and prints
the PDF correctly. I also tried Adobe Acrobat Reader 5.05 on Windows ME, and it
opens and prints the PDF correctly. Maybe it is just a Windows 2000 issue?
Comment 2 Warren Togami 2002-06-03 17:20:03 EDT
I had a similar problem in Red Hat 7.2 with Win2000 not being able to read a any
KDE generated PDF's, but only after I manually installed hpijs.  Uninstalled
hpijs and it worked fine.

(hpijs is the print drivers for HP inkjet printers, now included by default in
Red Hat 7.3.)
Comment 3 Tim Waugh 2002-06-10 12:57:54 EDT
We can reproduce this problem in-house with W2000.
Comment 4 Warren Togami 2002-06-10 13:39:27 EDT
It is in fact hpijs related?
Comment 5 Tim Waugh 2002-06-11 03:20:16 EDT
I don't think so.  The /Content-for-blank-pages explanation seems more likely. 
 
But it's strange that it's just W2000 that's affected.
Comment 6 Tammy Fox 2002-06-11 18:13:00 EDT
From http://www.cs.wisc.edu/~ghost/doc/cvs/History7.htm:

Fixes problems:
	- Empty pages included a Contents entry whose value was an empty
array: the spec allows this, and AR3 and 4 accept it, but AR5 rejects it.
(gdevpdf.c [1.34]: 2001/06/29 06:52:13 lpd)

It looks like the latest version corrects this error.
Comment 7 Tammy Fox 2002-07-04 18:59:03 EDT
Can someone with Windows 2000 using Adobe Acrobat version 5.05 try to view
http://people.redhat.com/tfox/rhl-cg-en.pdf? I produced it with ghostscript
7.05, which is supposed to fix the problem.
Comment 8 Warren Togami 2002-07-05 02:03:06 EDT
Confirmed.  I can read it on Windows 2000 with Adobe Acrobat Reader 5.0.5 9/24/2001.
Comment 9 Tim Waugh 2002-07-05 03:58:36 EDT
Great.

Note You need to log in before you can comment on or make changes to this bug.