Bug 658100 - Mock building automake16 fails when using i386 arch
Summary: Mock building automake16 fails when using i386 arch
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: automake16
Version: 6.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Karsten Hopp
QA Contact: qe-baseos-tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-29 11:04 UTC by Leonard den Ottolander
Modified: 2012-07-04 13:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-04 13:19:07 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Leonard den Ottolander 2010-11-29 11:04:37 UTC
When building automake16 under mock using the Fedora 14 epel-6-i386 configuration the build fails on a single test not succeeding.

FAIL: lex5.test
 
The same build with the x86_64 configuration succeeds.

automake16-1.6.3-18.el6.1.src.rpm

Comment 2 Karsten Hopp 2010-11-29 13:31:38 UTC
I remember that the lex tests fail when you have byacc installed. Make sure that it doesn't get pulled into the buildroot by another package.

Comment 3 Leonard den Ottolander 2010-11-29 14:07:21 UTC
byacc is not installed in the mock build root. And even if it were, how is this not a bug?

Comment 4 Leonard den Ottolander 2010-11-29 15:02:24 UTC
As I am building RHEL6 from source on 6beta and apply updates to the mock root using a local [updates] repo added to the epel-6 configs the build roots are in constant flux. On top of that I rebuild glib2-2.22.5-5.el6 with the freshly built gcc-4.4.4-13.el6, replacing the original rpms I built with the beta compiler, so I can no longer reconstruct that build root as it was. In the current build root I can not reproduce this issue.

In the future I will make sure to rpm -qa the build root when I encounter such issues, and will try to make sure to keep around all rpms. Just close as NOTABUG and sorry for the confusion.

Comment 5 RHEL Program Management 2011-07-05 23:45:21 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.


Note You need to log in before you can comment on or make changes to this bug.