Bug 658404 - ipa-server-install --selfsign fails because /usr/share/ipa/html/ca.crt is missing
Summary: ipa-server-install --selfsign fails because /usr/share/ipa/html/ca.crt is mis...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: freeIPA
Classification: Retired
Component: ipa-server
Version: 2.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Rob Crittenden
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-30 09:18 UTC by Pierre Carrier
Modified: 2015-01-04 23:45 UTC (History)
4 users (show)

Fixed In Version: freeipa-2.0.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-28 09:39:18 UTC


Attachments (Terms of Use)
/var/log/ipaserver-install.log (171.25 KB, text/x-log)
2010-11-30 09:19 UTC, Pierre Carrier
no flags Details

Description Pierre Carrier 2010-11-30 09:18:44 UTC
Description of problem:

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
On a minimal F14 install (no updates, very few extra packages installed):
1. added http://jdennis.fedorapeople.org/ipa-devel/ipa-devel-fedora.repo in
/etc/yum.repos.d
2. as per bug 657598, # yum install mx4j
3. # yum install ipa-server
4. as per bug 658314, # yum install krb5-pkinit-openssl
5. in /etc/hosts:
127.0.0.1 localhost localhost.localdomain
::1 localhost localhost.localdomain
1.2.3.4 main.beurk
6. HOSTNAME=main.beurk in /etc/sysconfig/network and # hostname main.beurk
7. # ipa-server-install --selfsign
8. All defaults but the passwords (same as root password)
9. Installation fails because of NOTABUG 658319, so # service messagebus start && chkconfig messagebus on
10. # ipa-server-install --uninstall
11. # ipa-server-install --selfsign
  
Actual results:
--- 8< ---
  [13/16]: creating X509 ipaserver-install.log certificate for PKINIT
Unexpected error - see ipaserver-install.log for details:
 [Errno 2] No such file or directory: '/usr/share/ipa/html/ca.crt'
error: file /usr/share/ipa/html/ca.crt: No such file or directory
--- >8 ---


Expected results:
- Installation proceeds

Additional info:
- Please find /var/log/ipaserver-install.log attached.

Comment 1 Pierre Carrier 2010-11-30 09:19:32 UTC
Created attachment 463672 [details]
/var/log/ipaserver-install.log

Comment 2 Dmitri Pal 2010-11-30 15:01:12 UTC
https://fedorahosted.org/freeipa/ticket/544

Comment 3 Dmitri Pal 2011-02-10 19:52:58 UTC
Fixed in: bfaea1dd78bbf6de0248ef8e33784d57ead9d24a


Note You need to log in before you can comment on or make changes to this bug.