Bug 658817 - Update cryptsetup to new version
Update cryptsetup to new version
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cryptsetup-luks (Show other bugs)
6.0
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Milan Broz
Release Test Team
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-01 06:49 EST by Milan Broz
Modified: 2013-02-28 23:10 EST (History)
10 users (show)

See Also:
Fixed In Version: cryptsetup-luks-1.2.0
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 09:29:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full output of make check (30.34 KB, application/octet-stream)
2011-02-18 09:46 EST, Alexander Todorov
no flags Details

  None (edit)
Description Milan Broz 2010-12-01 06:49:11 EST
Description of problem:

Because of planned encryption suppport in LVM in RHEL6 lifecycle we need to update cryptsetup (and libcryptsetup) to new version (1.2.x).

This should happen before any possible certifications for disk encryption (like FIPS) because later update of encryption path can cause problems (need revalidation).

Current set of features in 1.2.0 is described here http://code.google.com/p/cryptsetup/wiki/Cryptsetup120

Provided library is fully backward compatible so no need for recompilation of other code. New version also have more regression tests which will be updated in RHEL too.
Comment 8 Alexander Todorov 2011-02-18 09:46:07 EST
In latest trees we have cryptsetup-luks-1.2.0-2.el6. 

I've taken the sources from the src.rpm package, applied the patches (rpmbuild -bp) and then in the extracted sources dir I run: 

# ./configure
# make
# make check

This will execute the test cases supplied with the package. The results are:

PASS: api-test
PASS: compat-test
PASS: align-test
PASS: mode-test
PASS: password-hash-test
==================
All 5 tests passed
==================


Will attach full log.
Comment 9 Alexander Todorov 2011-02-18 09:46:34 EST
Created attachment 479526 [details]
full output of make check
Comment 10 errata-xmlrpc 2011-05-19 09:29:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0597.html

Note You need to log in before you can comment on or make changes to this bug.