Bug 65894 - kdebase-3.0.0-12 - kicker leaks memory
kdebase-3.0.0-12 - kicker leaks memory
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-03 16:59 EDT by James Manning
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-22 13:41:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Manning 2002-06-03 16:59:54 EDT
Description of Problem:
kicker starts out around 12MB of memory (seems a tad high for what it does, but
anyway).  Over the course of time (sometimes 2 weeks), it reaches well over
100MB on my machine.  I think it's the flashing icon on new chat that kinkatta
is doing and kicker isn't freeing that memory correctly, but I'm not sure. 
Passive attempts at figuring out a cause haven't gone well, so I wanna go ahead
and get some advice on what to track where and what I can report here to help
track it down

Version-Release number of selected component (if applicable):
kdebase-3.0.0-12

How Reproducible:
100%

Steps to Reproduce:
1. start normal kde
2. (possibly) start kinkatta or another app that does icon flashing
3. watch memory usage increase to insane levels

Actual Results:
memory usage grows, although slowly over time

Expected Results:
no increase in memory usage

Additional Information:
very normal fresh 7.3 install
Comment 1 James Manning 2002-06-07 11:36:36 EDT
it's been a few days and it's up to 45-55MB from a start of 12-16

jmm@jmm /proc/11348> cat /proc/$(pgrep -f kicker)/status
Name:   kdeinit
State:  S (sleeping)
Tgid:   11348
Pid:    11348
PPid:   1
TracerPid:      0
Uid:    500     500     500     500
Gid:    500     500     500     500
FDSize: 32
Groups: 500
VmSize:    56272 kB
VmLck:         0 kB
VmRSS:     44376 kB
VmData:    34732 kB
VmStk:        88 kB
VmExe:        36 kB
VmLib:     19808 kB
SigPnd: 0000000000000000
SigBlk: 0000000080000000
SigIgn: 8000000000001002
SigCgt: 00000003800144a9
CapInh: 0000000000000000
CapPrm: 0000000000000000
CapEff: 0000000000000000

jmm@jmm /proc/11348> cat statm
11312 11109 2450 9 0 11100 8726

jmm@jmm /proc/11348> sort -n -r +4 maps|head
4142f000-4144a000 r--s 00000000 00:04 46235659   /SYSV00000000 (deleted)
4140a000-41425000 r--s 00000000 00:04 46137353   /SYSV00000000 (deleted)
41384000-4139f000 r--s 00000000 00:04 46104584   /SYSV00000000 (deleted)
4135a000-41375000 r--s 00000000 00:04 45907973   /SYSV00000000 (deleted)
412ee000-412ef000 rw-p 0000e000 03:02 229066    
/usr/lib/kde3/plugins/styles/highcolor-gcc2.96.so
412df000-412ee000 r-xp 00000000 03:02 229066    
/usr/lib/kde3/plugins/styles/highcolor-gcc2.96.so
41284000-4128a000 r--p 00000000 03:02 210691     /usr/lib/locale/en_US/LC_COLLATE
4128b000-412b6000 r--p 00000000 03:02 210690     /usr/lib/locale/en_US/LC_CTYPE
4128a000-4128b000 r--p 00000000 03:02 208656     /usr/lib/locale/en_US/LC_NUMERIC
40082000-40085000 rw-p 00035000 03:02 196730     /usr/lib/libkparts-gcc2.96.so.2.0.0
Comment 2 James Manning 2002-06-07 11:48:14 EDT
as an addendum, this is the KDE-fresh-start scenario where kdeinit is calling
kicker, but I see the same behavior even if I kill kicker and then start it
manually (cmdline or alt-f2).
Comment 3 James Manning 2002-07-08 11:17:05 EDT
left it up over the long weekend - SZ is 400M, RSS was 211M when I unlocked the
screen saver but has been dropping since I've been needing to swap in stuff like
Mozilla to post this comment on the bug

jmm@jmm /home/jmm> cd /proc/$(pgrep -f kicker)
jmm@jmm /proc/1690> cat status
Name:   kdeinit
State:  S (sleeping)
Tgid:   1690
Pid:    1690
PPid:   1
TracerPid:      0
Uid:    500     500     500     500
Gid:    500     500     500     500
FDSize: 32
Groups: 500
VmSize:   427420 kB
VmLck:         0 kB
VmRSS:    177468 kB
VmData:   405880 kB
VmStk:        88 kB
VmExe:        36 kB
VmLib:     19808 kB
SigPnd: 0000000000000000
SigBlk: 0000000080000000
SigIgn: 8000000000001002
SigCgt: 00000003800144a9
CapInh: 0000000000000000
CapPrm: 0000000000000000
CapEff: 0000000000000000
jmm@jmm /proc/1690> cat statm
102437 45995 798 2 0 45993 45142
jmm@jmm /proc/1690> sort -n -r +4 maps|head
41428000-41443000 r--s 00000000 00:04 983052     /SYSV00000000 (deleted)
4140d000-41428000 r--s 00000000 00:04 950283     /SYSV00000000 (deleted)
41387000-413a2000 r--s 00000000 00:04 917514     /SYSV00000000 (deleted)
412ee000-412ef000 rw-p 0000e000 03:02 229066    
/usr/lib/kde3/plugins/styles/highcolor-gcc2.96.so
412df000-412ee000 r-xp 00000000 03:02 229066    
/usr/lib/kde3/plugins/styles/highcolor-gcc2.96.so
41284000-4128a000 r--p 00000000 03:02 210691    
/usr/lib/locale/en_US/LC_COLLATE;3d1916ae (deleted)
4128b000-412b6000 r--p 00000000 03:02 210690    
/usr/lib/locale/en_US/LC_CTYPE;3d1916ae (deleted)
4128a000-4128b000 r--p 00000000 03:02 208656    
/usr/lib/locale/en_US/LC_NUMERIC;3d1916ae (deleted)
40082000-40085000 rw-p 00035000 03:02 196730     /usr/lib/libkparts-gcc2.96.so.2.0.0
4004d000-40082000 r-xp 00000000 03:02 196730     /usr/lib/libkparts-gcc2.96.so.2.0.0
jmm@jmm /proc/1690>
Comment 4 James Manning 2002-07-08 11:25:12 EDT
in case it helps the debug:

sent a SIGTERM to the kicker 5 minutes ago and it hasn't exited. 
.xsession-errors logged one line:

kicker: sighandler called
Comment 5 Rex Dieter 2002-07-08 11:27:39 EDT
FYI, in my usage of both kdebase-3.0.1 and kdebase-3.0.2, I do not experience  
any problems like this, in general... though I'm not really using 
flashing/animating icons much.
Comment 6 Ngo Than 2005-06-22 13:41:20 EDT
it's fixed in current FC4

Note You need to log in before you can comment on or make changes to this bug.