Bug 65904 - perl-BSD-Resource leaves empty directories after uninstallation
perl-BSD-Resource leaves empty directories after uninstallation
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: perl-BSD-Resource (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-03 19:50 EDT by Enrico Scholz
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2002-06-03 19:50:01 EDT
Description of Problem:

The package contains a lot of files but does not own the directories where
they are located. Thus, after deinstallation a lot of orphaned directories will
remain.


Steps to Reproduce:
1. 
# ls -d
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi-stdio/auto/BSD/Resource
ls:
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi-stdio/auto/BSD/Resource:
No such file or directory

2. 
# rpm -U /usr/src/redhat/RPMS/i386/perl-BSD-Resource-1.14-17.i386.rpm 
# rpm -e perl-BSD-Resource

3. 
# ls -d
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi-stdio/auto/BSD/Resource  
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi-stdio/auto/BSD/Resource


Actual Results:

Directory tested at 1. still exists at 4.


Expected Results:

After 3. the system shall be in the same state as before 2.
Comment 1 Chip Turner 2002-06-04 12:47:02 EDT
fixed in rawhide
Comment 2 Red Hat Bugzilla 2006-02-21 13:49:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.