Bug 659171 - expose scheduler's URL in a job xml (for e.g. reservesys)
Summary: expose scheduler's URL in a job xml (for e.g. reservesys)
Keywords:
Status: CLOSED DUPLICATE of bug 646773
Alias: None
Product: Beaker
Classification: Retired
Component: scheduler
Version: 0.5
Hardware: Unspecified
OS: Unspecified
low
medium vote
Target Milestone: ---
Assignee: Bill Peck
QA Contact:
URL:
Whiteboard:
Depends On: 661761
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-02 03:04 UTC by Raymond Mancy
Modified: 2014-12-08 01:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-09 05:45:20 UTC


Attachments (Terms of Use)

Description Raymond Mancy 2010-12-02 03:04:32 UTC
I've made a small change on my dev for the reservesys task to task a param for the inventory server so it's not harcoded. Need to change the server code so it can automatically populate this param in the XML.

Comment 1 Marian Csontos 2010-12-02 09:12:24 UTC
IMO this looks more like a job property, not a task's param - i.e. "this job runs on such-and-such scheduler", and not "this task should know the scheduler is so-and-so" ?

BTW, is this assigned to test-harness (and thus me) correctly?

Comment 2 Raymond Mancy 2010-12-02 22:53:21 UTC
Well if I set it as a task param I know that it is easily accessible by the task (which is exactly what I need). Perhaps it was short sighted, but I've got no idea how to get it in any other way.
I guess the correct place to have it is as a Job level entry, but I have no idea to do this. 

I didn't mean to assign this to you actually. I think you have more important things to do.

Comment 3 Marian Csontos 2011-01-25 10:13:17 UTC
I suggest implementing this as a global param for the job element: see Bug 658455.

On harness side that would be a really simple change.

Comment 4 Dan Callaghan 2012-07-09 05:29:38 UTC
Could we just dupe this to bug 646773?

Comment 5 Raymond Mancy 2012-07-09 05:45:20 UTC
Yes.

*** This bug has been marked as a duplicate of bug 646773 ***


Note You need to log in before you can comment on or make changes to this bug.