This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 659273 - VNC server crashes at startup if more than 256 interfaces are defined on the system
VNC server crashes at startup if more than 256 interfaces are defined on the ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: vnc (Show other bugs)
5.6
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Tim Waugh
qe-baseos-daemons
: Patch, ZStream
: 647256 (view as bug list)
Depends On:
Blocks: 673976
  Show dependency treegraph
 
Reported: 2010-12-02 05:57 EST by Olivier Fourdan
Modified: 2013-10-02 07:05 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 07:05:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Script to create the interfaces (431 bytes, text/plain)
2010-12-02 05:57 EST, Olivier Fourdan
no flags Details
Patch to apply to xorg-x11-server source tree prior to build vnc-server (447 bytes, patch)
2010-12-02 05:59 EST, Olivier Fourdan
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 20675 None None None Never

  None (edit)
Description Olivier Fourdan 2010-12-02 05:57:45 EST
Created attachment 464223 [details]
Script to create the interfaces

Description of problem:

With more than 256 interfaces on a system, the VNC server will fail to start and
crash (that also affects all server variants Xorg, Xnest, etc., see bug #659263)

Version-Release number of selected component (if applicable):

vnc-4.1.2-14.el5_5.4

How reproducible:

Always

Steps to Reproduce:
1. Create more then 250 network interfaces with the attached shell script
2. Start the Xvnc server
  
Actual results:

Xvnc crashes

Expected results:

No crash

Additional info:

The bug in in the X server, on which Xvnc is built upon.

It's https://bugs.freedesktop.org/show_bug.cgi?id=20675 fixed by
http://cgit.freedesktop.org/xorg/xserver/commit/?id=0eb19f9437b7d8c19592e49eedb028771d300d80

Applying the patch attached to the xorg-x11-server sources tree in VNC spec file fixes the issue, ie something like:

    Patch9999:  xorg-server-1.1.1-fix-bug-20675-git-0eb19f94.patch
    ...
    %prep
    %setup -q -n vnc-%{vnc_version}-unixsrc -a1
    mkdir -p unix/xorg-server-1.1.1/hw/vnc
    pushd unix/xorg-server-1.1.1
    bzip2 -dc %{SOURCE2} | tar -xkf - || :
    %patch9999 -p1 -b .0eb19f94
    popd

Or using an update source tree for xorg-x11-server with the patch included (for example once bug #659263 is resolved).
Comment 1 Olivier Fourdan 2010-12-02 05:59:51 EST
Created attachment 464224 [details]
Patch to apply to xorg-x11-server source tree prior to build vnc-server

This is the patch that fixes freedesktop.org bug 20675.
Comment 2 Adam Tkac 2010-12-02 06:26:44 EST
*** Bug 647256 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.