This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 659641 - ibus: following a system reboot, some ibus components do not work till ibus is restarted
ibus: following a system reboot, some ibus components do not work till ibus i...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
14
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-03 05:02 EST by Harshula Jayasuriya
Modified: 2011-06-08 03:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-10 02:58:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harshula Jayasuriya 2010-12-03 05:02:02 EST
e.g. 1: Steps
1) In IBus Preferences, set "Show language panel" to "When active"
2) Reboot your system
3) Relogin, activate your default IM
4) The panel will not appear

e.g. 2: Steps
1) Reboot your system
2) Select the XKB "Sinhala; Sinhalese - Sri Lanka" layout
3) Activate the aforementioned XKB layout
4) Typing results in English letters

Workaround: Restart IBus and both problems are solved.

Regards,
Harshula
Comment 1 Harshula Jayasuriya 2010-12-03 05:07:51 EST
$ cat /etc/sysconfig/keyboard
KEYTABLE="us"
MODEL="pc105+inet"
LAYOUT="us"
KEYBOARDTYPE="pc"

$ gconftool-2 --get /desktop/gnome/peripherals/keyboard/kbd/layouts
[us,lk]
$ gconftool-2 --get /desktop/gnome/peripherals/keyboard/kbd/model

$ gconftool-2 --get /desktop/gnome/peripherals/keyboard/kbd/options
[ctrl	ctrl:swapcaps,grp	grp:shifts_toggle]
Comment 2 Harshula Jayasuriya 2010-12-03 05:14:18 EST
Bug 596395: ibus: language panel often disappears:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=596395
Comment 3 fujiwara 2010-12-06 01:53:51 EST
(In reply to comment #0)

I cannot reproduce both.

> e.g. 1: Steps
> 1) In IBus Preferences, set "Show language panel" to "When active"
> 2) Reboot your system
> 3) Relogin, activate your default IM
> 4) The panel will not appear

Please attach the screenshot.
% gnome-panel-screenshot

> 
> e.g. 2: Steps
> 1) Reboot your system
> 2) Select the XKB "Sinhala; Sinhalese - Sri Lanka" layout
> 3) Activate the aforementioned XKB layout
> 4) Typing results in English letters
> 

Can you get self.__default_layout in the constructor of /usr/lib/python2.7/site-packages/ibus/xkblayout.py ?
@@ -39,6 +39,11 @@
         self.__default_layout = self.get_layout()
         self.__default_model = self.get_model()
         self.__default_option = self.get_option()
+        f = open('/var/tmp/xkb.log', 'w')
+        f.write('layout: ' + self.__default_layout + '\n')
+        f.write('model: ' + self.__default_model + '\n')
+        f.write('option: ' + self.__default_option + '\n')
+        f.close()
         self.__xkb_latin_layouts = []
         if config != None:
             self.__xkb_latin_layouts = list(self.__config.get_value("general",


Also what is the value of the default XKB?

% /usr/libexec/ibus-xkb --get
layout: us,lk
model: ,
option: ctrl:swapcaps,grp:shifts_toggle
Comment 4 Harshula Jayasuriya 2010-12-07 21:38:49 EST
(In reply to comment #3)
 
> I cannot reproduce both.
> 
> > e.g. 1: Steps
> > 1) In IBus Preferences, set "Show language panel" to "When active"
> > 2) Reboot your system
> > 3) Relogin, activate your default IM
> > 4) The panel will not appear

I thought you reproduced this one back in September?
 
> Please attach the screenshot.
> % gnome-panel-screenshot

I have my panel set to autohide, so the screenshot will not be helpful. I'll describe it for you, the gnome panel icon shows the IM logo when activated, but the language panel that usually appears at the bottom right hand corner when the IM is activated does not appear. After a IBus restart it will appear when activated.

> > e.g. 2: Steps
> > 1) Reboot your system
> > 2) Select the XKB "Sinhala; Sinhalese - Sri Lanka" layout
> > 3) Activate the aforementioned XKB layout
> > 4) Typing results in English letters
> > 
> 
> Can you get self.__default_layout in the constructor of
> /usr/lib/python2.7/site-packages/ibus/xkblayout.py ?
---------------------------------------
layout: us,lk
model: ,
option: ctrl:swapcaps,grp:shifts_toggle
---------------------------------------
 
> Also what is the value of the default XKB?
---------------------------------------
$ /usr/libexec/ibus-xkb --get
layout: us,lk
model: ,
option: ctrl:swapcaps,grp:shifts_toggle
---------------------------------------
Comment 5 fujiwara 2010-12-08 01:37:02 EST
(In reply to comment #4)
> I thought you reproduced this one back in September?

No, I don't think so.
Do you see your problem on fedora 14?

> 
> > Please attach the screenshot.
> > % gnome-panel-screenshot
> 
> I have my panel set to autohide, so the screenshot will not be helpful. I'll
> describe it for you, the gnome panel icon shows the IM logo when activated, but
> the language panel that usually appears at the bottom right hand corner when
> the IM is activated does not appear. After a IBus restart it will appear when
> activated.

Please observe how to reproduce your bug with the reproducing steps.
Do you mean the autohide is required to reproduce the bug?
Sorry, I don't understand your problem exactly. I would be still interested in the screenshot how your panel icon is not shown.

> 
> > > e.g. 2: Steps
> > > 1) Reboot your system
> > > 2) Select the XKB "Sinhala; Sinhalese - Sri Lanka" layout
> > > 3) Activate the aforementioned XKB layout
> > > 4) Typing results in English letters
> > > 
> > 
> > Can you get self.__default_layout in the constructor of
> > /usr/lib/python2.7/site-packages/ibus/xkblayout.py ?
> ---------------------------------------
> layout: us,lk
> model: ,
> option: ctrl:swapcaps,grp:shifts_toggle
> ---------------------------------------

Hmm.., it's curious.
I guess you might not explain the important steps or you have some special settings.

> 
> > Also what is the value of the default XKB?
> ---------------------------------------
> $ /usr/libexec/ibus-xkb --get
> layout: us,lk
> model: ,
> option: ctrl:swapcaps,grp:shifts_toggle
> ---------------------------------------

OK, currently I have the same settings you described but don't reproduce your problem.
Comment 6 fujiwara 2010-12-08 01:42:17 EST
Or if you provide a vnc session with root account, I can check your problem directly.
Comment 7 Harshula Jayasuriya 2010-12-08 02:45:50 EST
(In reply to comment #6)
> Or if you provide a vnc session with root account, I can check your problem
> directly.

No, that's not an option. :-)

How about we do this slightly differently. Can you tell me how I can tap and monitor the communication between:

1) IBus and the GTK language panel
2) IBus and ibus-engine-xkb

Thanks,
#
Comment 8 fujiwara 2010-12-08 03:34:35 EST
(In reply to comment #7)
> 1) IBus and the GTK language panel
> 2) IBus and ibus-engine-xkb

Hmm.., I think I showed how to debug ibus.
If you doubt your problem is a timing issue, it would be good to add the logging in comment #3.

If you want to run ibus panel directly:

% env IBUS_PREFIX=/usr python /usr/share/ibus/ui/gtk/main.py

You could add some print command.
Let me know if you need more helps.
Comment 9 Harshula Jayasuriya 2011-02-10 03:18:17 EST
1) Did you try to reproduce this on bare metal? i.e. not in a VM?

2) If I can reproduce this in F15 when it releases, I'll reopen this BZ.
Comment 10 fujiwara 2011-02-10 03:46:01 EST
(In reply to comment #9)
> 1) Did you try to reproduce this on bare metal? i.e. not in a VM?

Yes, I did.
Also it's useful if your problem can be reproduce in a VM.
Probably it's good to provide the access on your hosts since I cannot reproduce your problem and you don't proceed the debug.

> 2) If I can reproduce this in F15 when it releases, I'll reopen this BZ.

OK. Currently I have F15 at office and F14 at home. Others are VMs.
Comment 11 Harshula Jayasuriya 2011-02-21 05:57:34 EST
Note: still reproducible in F14 with:

ibus-1.3.9-2.fc14.x86_64
ibus-anthy-1.2.5-3.fc14.x86_64
ibus-devel-1.3.9-2.fc14.x86_64
ibus-gtk2-1.3.9-2.fc14.x86_64
ibus-libs-1.3.9-2.fc14.x86_64
ibus-m17n-1.3.1-8.fc14.x86_64
ibus-pinyin-1.3.11-1.fc14.x86_64
ibus-pinyin-db-open-phrase-1.3.11-1.fc14.noarch

This bug can be reproduced consistently after a reboot. Can you please suggest any useful debugging techniques for capturing communication to the "GTK language panel" immediately after a reboot? I've read over the BZ again, so far there has *not* been any useful debugging techniques suggested.
Comment 12 fujiwara 2011-02-21 20:36:58 EST
Hmm.., I'm not sure what you try to do.
I think I already gave the suggestion or read the document of gdb.

(In reply to comment #8)
> If you want to run ibus panel directly:
> 
> % env IBUS_PREFIX=/usr python /usr/share/ibus/ui/gtk/main.py
> 
> You could add some print command.
> Let me know if you need more helps.

Probably file io could help the debugging if that would be a timing issue.
Probably it's good to provide the access on your hosts since I cannot reproduce
your problem and you don't proceed the debug.

On the other hand, I guess your issue might not be ibus since I cannot reproduce it.
I'll try again your situation today after I go to home.
Comment 13 Harshula Jayasuriya 2011-02-21 21:00:39 EST
The original description (https://bugzilla.redhat.com/show_bug.cgi?id=659641#c0) contains the exact steps followed to reproduce the problem.

As I said earlier (https://bugzilla.redhat.com/show_bug.cgi?id=659641#c7). Direct access to my system is "not an option."

As I've stated earlier, this is only reproducible immediately after a reboot. So restarting and directly running the GTK language panel doesn't make sense. A useful debugging technique would be a way to tap the IBus communication and observe the communication to GTK language panel. Is there an easy way to do that?
Comment 14 fujiwara 2011-02-22 20:12:54 EST
(In reply to comment #13)
> The original description
> (https://bugzilla.redhat.com/show_bug.cgi?id=659641#c0) contains the exact
> steps followed to reproduce the problem.

I think this does not include the required steps to reproduce your problem.
I tried the steps yesterday again but I still cannot reproduce your problem.

> 
> As I said earlier (https://bugzilla.redhat.com/show_bug.cgi?id=659641#c7).
> Direct access to my system is "not an option."

Then I think it's good to just wait for another bug report which will include the proper steps or provide the access.

> 
> As I've stated earlier, this is only reproducible immediately after a reboot.
> So restarting and directly running the GTK language panel doesn't make sense. A
> useful debugging technique would be a way to tap the IBus communication and
> observe the communication to GTK language panel. Is there an easy way to do
> that?

Not sure since I don't see any problems. Maybe I think it would not be your task.

Basically I have thought if it's a good bug report:
 - Report the exact steps and software & hardware environments which the bug evaluators can reproduce it
 - Provide the access of test environments
 - Report the root cause
 - Report the patch

Otherwise I'd think it would be a low priority.
Comment 15 Harshula Jayasuriya 2011-03-03 00:41:05 EST
> > As I've stated earlier, this is only reproducible immediately after a reboot.
> > So restarting and directly running the GTK language panel doesn't make sense. A
> > useful debugging technique would be a way to tap the IBus communication and
> > observe the communication to GTK language panel. Is there an easy way to do
> > that?
> 
> Not sure since I don't see any problems. Maybe I think it would not be your
> task.

Since you can't reproduce it and I can, it makes sense for me to do the debugging if you are able to suggest appropriate debugging techniques.
Comment 16 Harshula Jayasuriya 2011-06-08 03:03:57 EDT
(In reply to comment #9)
> 2) If I can reproduce this in F15 when it releases, I'll reopen this BZ.

I can NOT reproduce both the problems in F15. I have tested multiple times. As far as I'm concerned this is CLOSED - CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.