Bug 659684 - Xserver-1.10: Fatal server error: Unrecognized option: -nr
Xserver-1.10: Fatal server error: Unrecognized option: -nr
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-03 08:37 EST by Martin Kho
Modified: 2010-12-06 15:36 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-06 09:35:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kho 2010-12-03 08:37:57 EST
Description of problem:

After updating to XServer 1.10 X fails to start with the message (in /var/log/kdm.log): "Fatal server error: Unrecognized option: -nr". 


The flag "-nr" (ServerArgsLocal=-nr -nolisten tcp in /etc/kde/kdm/kdmrc) is 'replaced' by the flag "-background none", see [1]. Just replacing "-nr" by "-background none" is not enough... :-(


[1] http://lists.fedoraproject.org/pipermail/scm-commits/2010-December/527559.html

Version-Release number of selected component (if applicable):
kdm-4.5.80-7.fc15.x86_64
xorg-x11-server-Xorg-1.9.99.1-1.20101201.fc15.x86_64

How reproducible:
Just boot into fc15 and kdm as login manager 
  
Actual results:
X crashes, no kdm login

Expected results:
X does not crash, kdm login

Additional info:
Comment 1 Rex Dieter 2010-12-03 08:53:25 EST
Thanks for the heads-up.

Changing kdmrc options *may* require a reboot (or runlevel change, Restarting X session often isn't enough).  How did you test?
Comment 2 Martin Kho 2010-12-03 09:40:40 EST
Hi Rex,

1. I normally tried to (re)boot -> black screen -> "Fatal server error
Unrecognized option: -nr"

2. Booted into text mode (runlevel 3) -> replaced "-nr" by "-background none"
in /etc/kde/kdm/kdmrc -> "Fatal server error:
xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call"
He, this one have we see before :-) [1]

3. For the time being I boot without Plymouth.


Martin Kho


[1] https://bugzilla.redhat.com/show_bug.cgi?id=551310
Comment 3 Rex Dieter 2010-12-03 09:45:32 EST
Well, we'll give s/-nr/-background none/ a try,

%changelog
* Fri Dec 03 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.6-2
- drop old Conflicts
- Xserver-1.10: Fatal server error: Unrecognized option: -nr (#659684)
Comment 4 Martin Kho 2010-12-03 09:57:43 EST
Hi,

Are you sure it will be enough to change "-nr" by "-background none"? I've tried it but that didn't work. See comment #2.

May be Peter Hutterer can tell you more. He created the patches for gdm.

Martin Kho
Comment 5 Kevin Kofler 2010-12-03 10:23:16 EST
Well, if that change is not sufficient, then there is an additional bug also triggered by the new X server, separate from this one.
Comment 6 Martin Kho 2010-12-03 10:37:21 EST
Hi,

For gdm Peter Hutterer is doing the following:


diff --git a/plymouth.patch b/plymouth.patch
index 0658664..b74aaac 100644
--- a/plymouth.patch
+++ b/plymouth.patch
@@ -222,7 +222,7 @@ index ba10386..3ec21e9 100644
 +        char *vt;
 +
 +        g_free (server->priv->command);
-+        server->priv->command = g_strdup (X_SERVER " -nr -verbose");
++        server->priv->command = g_strdup (X_SERVER " -background none -verbose");
 +        vt = get_active_vt_as_string ();
 +        res = gdm_server_spawn (server, vt);
 +        g_free (vt);

Martin Kho
Comment 7 Martin Kho 2010-12-06 03:12:34 EST
Hi Rex,

You have golden fingers :-) 

The changes you made to kde-settings do work (with kde 4.6 beta 2 at least).

X is running on vt1. 

This report can be closed, I suppose.

Thanks again,

Martin Kho
Comment 8 Rex Dieter 2010-12-06 09:35:38 EST
thanks for the confirmation.
Comment 9 Martin Kho 2010-12-06 14:01:38 EST
Hi,

I've bad news :-( After rebooting a few times I got:

1. Normal boot -> login screen -> X runs on vt1 (good)
2. Server crash -> "Fatal server error: xf86OpenConsole: VT_WAITACTIVE failed: Interrupted system call"
3. Boot -> Interrupt Plymouth by pressing the ESC-key ->  login screen -> X runs on vt7 (not good)

The problem seems to be related to the new boot process:

Plymouth is started by dracut and 'is taken over' by systemd. Sometimes the takeover is successful sometime it's not.

May be this report need to be reopened, sorry.


Martin Kho
Comment 10 Rex Dieter 2010-12-06 14:05:44 EST
Open a new bug please, that is almost certainly a separate issue than this.
Comment 11 Martin Kho 2010-12-06 14:21:30 EST
Hi Rex,

I'll file a bug against Plymouth, because the -nr flag was introduced with this package:

In [1] I read:

"krh has a patch which adds a -nr ("no root") option which makes the root window keep the framebuffer contents that were around when X started"

Martin Kho

[1] http://fedoraproject.org/wiki/Releases/FeatureBetterStartup
Comment 12 Martin Kho 2010-12-06 15:36:49 EST
Hi,

FYI: As requested I've opened bug #660461


Martin Kho

Note You need to log in before you can comment on or make changes to this bug.