Bug 66000 - grubby crashed
grubby crashed
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-06-04 15:25 EDT by Bill Nottingham
Modified: 2014-03-16 22:27 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-16 23:56:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the grub.conf in use (556 bytes, text/plain)
2002-06-04 15:25 EDT, Bill Nottingham
no flags Details
another grub.conf where grubby crashes (2.06 KB, text/plain)
2002-08-14 19:26 EDT, Nils Philippsen
no flags Details
full upgrade/log for -re1202.nightly-i386, RH-everything-upgrade_from_7.3-mirror-english-nfs-GUI (116.25 KB, text/plain)
2002-12-03 13:04 EST, Mike McLean
no flags Details

  None (edit)
Description Bill Nottingham 2002-06-04 15:25:06 EDT
[root@apone athlon]# rpm -ivh kernel-2.4.18-0.40.athlon.rpm
Preparing...     ########################################### [100%]
   1:kernel                 ########################################### [100%]
/sbin/new-kernel-pkg: line 23:  2671 Segmentation fault      /sbin/grubby
--add-kernel=/boot/vmlinuz-$version $INITRD --copy-default --title "Red Hat
Linux ($version)"
[root@apone athlon]#
[root@apone athlon]# rpm -q mkinitrd
mkinitrd-3.4.3-1

grub.conf attached.
Comment 1 Bill Nottingham 2002-06-04 15:25:34 EDT
Created attachment 59625 [details]
the grub.conf in use
Comment 2 Erik Troan 2002-06-04 15:32:25 EDT
I can't recreate this... Do you have a machine I can see this on?
Comment 3 Erik Troan 2002-06-04 16:28:58 EDT
fixed in 3.4.4 (blush)

don't know why apone showed this so easily and other machines didn't -- pretty
basic bug
Comment 4 Mike McLean 2002-07-26 16:29:26 EDT
I'm seeing this in upgrade.log with re0726.1. Upgrades from both 7.2 and 7.3.

Upgrading mkinitrd-3.4.19-1.
Upgrading kernel-smp-2.4.18-7.80.
/sbin/new-kernel-pkg: line 247:  1078 Segmentation fault      /sbin/grubby
--add-kernel=/boot/vmlinuz-$version $INITRD --copy-default --title "$title"
--args="root=$rootdevice" --remove-kernel="TITLE=$title"
Upgrading iptables-1.2.5-5.
/var/tmp/rpm-tmp.22440: line 1: [: /var/tmp/rpm-tmp.22440: integer expression
expected
Upgrading kernel-2.4.18-7.80.
/sbin/new-kernel-pkg: line 247:  1427 Segmentation fault      /sbin/grubby
--add-kernel=/boot/vmlinuz-$version $INITRD --copy-default --title "$title"
--args="root=$rootdevice" --remove-kernel="TITLE=$title"

Comment 5 Mike McLean 2002-07-26 16:34:12 EDT
My logs show that it stopped after 0531.1 but reappeared with 0725.0.
Comment 6 Erik Troan 2002-07-26 21:46:45 EDT
This should be fixed in 3.4.20 -- please make sure you test and confirm.

The ip-tables problem is separate; I assume it got reported elsewhere.
Comment 7 Erik Troan 2002-07-26 21:49:12 EDT
I meant 3.4.19 -- please holler (loudly) if this fails in tonights build.
Comment 8 Mike McLean 2002-07-29 11:05:25 EDT
> I meant 3.4.19 -- please holler (loudly) if this fails in tonights build.

This was with 3.4.19-1, and I am seeing it with Milan-re0728.nightly.
Comment 9 Erik Troan 2002-08-07 17:54:15 EDT
Jeremey Katz fixed this.
Comment 10 Mike McLean 2002-08-13 19:25:05 EDT
I am still seeing this in upgrade.log with Milan-re0812.nightly and
Milan-re0813.nightly:

Upgrading mkinitrd-3.4.22-1.
Upgrading kernel-smp-2.4.18-7.95.
/sbin/new-kernel-pkg: line 247:  1029 Segmentation fault      /sbin/grubby
--add-kernel=/boot/vmlinuz-$version $INITRD --copy-default --title "$title"
--args="root=$rootdevice" --remove-kernel="TITLE=$title"
Comment 11 Nils Philippsen 2002-08-14 19:25:42 EDT
The same here:

root@wombat:~> rpm -ivh
/scratch/8.0/kernel/2.4.18-10.98/athlon/kernel-2.4.18-10.98.athlon.rpm  --oldpackage
Preparing...                ########################################### [100%]
   1:kernel                 ########################################### [100%]
/sbin/new-kernel-pkg: line 249:  6249 Segmentation fault      /sbin/grubby
--add-kernel=$bootPrefix/vmlinuz-$version $INITRD --copy-default --title
$version --args="root=$rootdevice" --remove-kernel="TITLE=$version" --lilo
root@wombat:~> rpm -qf /sbin/grubby
mkinitrd-3.4.23-1
Comment 12 Nils Philippsen 2002-08-14 19:26:45 EDT
Created attachment 70705 [details]
another grub.conf where grubby crashes
Comment 13 Mike McLean 2002-08-30 18:46:24 EDT
Still seeing this.
Comment 14 Jeremy Katz 2002-08-31 00:43:58 EDT
Nils, the crash you saw was due to the lilo.conf, not the grub.conf.  Mike -- is
the one you see when running with --lilo or not?
Comment 15 Mike McLean 2002-09-02 15:34:53 EDT
No, there is no --lilo in my cases.

I am only seeing this with 7.2 and 7.3 upgrade cases right now.  (This error
message has not appeared in a <7.2 upgrade case since late July).  I believe
that in all these cases, the original install used grub.  In all the kickstart
cases (either the 7.[23] install or the beta upgrade ks) I am using the
'bootloader' directive with no arguments.

It has also been observed with some manual upgrades (where I almost certainly
picked the defaults on the bootloader screen).
Comment 16 Mike McLean 2002-12-03 13:02:47 EST
still seeing this with -re1202.nightly
* ks upgrade
* RH-everything-upgrade_from_7.3-mirror-english-nfs-GUI
* mkinitrd-3.4.32-1.

Upgrading kernel-2.4.19-0.pp.20.
/sbin/new-kernel-pkg: line 249:  3183 Segmentation fault      /sbin/grubby
--add-kernel=$bootPrefix/vmlinuz-$version $INITRD --copy-default --title
"$title" --args="root=$rootdevice" --remove-kernel="TITLE=$title"
Comment 17 Mike McLean 2002-12-03 13:04:36 EST
Created attachment 87247 [details]
full upgrade/log for -re1202.nightly-i386, RH-everything-upgrade_from_7.3-mirror-english-nfs-GUI
Comment 18 Jeremy Katz 2003-01-05 23:41:12 EST
Commiting another fix to fix mikem's case.  If the default doesn't have root=,
we shouldn't try to use it as the default.  Will be in 3.4.34-1
Comment 19 Bill Nottingham 2003-10-16 23:56:32 EDT
Assuming fixed these days.

Note You need to log in before you can comment on or make changes to this bug.