Bug 660181 - KMix audio volume boosted to maximum level on dialog appearance
Summary: KMix audio volume boosted to maximum level on dialog appearance
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdemultimedia
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-12-06 01:28 UTC by Jack B.
Modified: 2011-05-17 00:41 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-17 00:41:12 UTC


Attachments (Terms of Use)

Description Jack B. 2010-12-06 01:28:55 UTC
Description of problem:
When system dialogues appear, the Internal Audio Analog Stereo volume is set to its maximum level on my fully updated Fedora 13. The machine is a Lenovo T61. I'm not entirely sure this is caused by KMix, but it probably is involved.

Version-Release number of selected component (if applicable):
KMix is version 3.7 on KDE 4.5.3.

How reproducible:
Provoke a dialogue. Interestingly, the Firefox close tabs dialogue doesn't result in this bug, but e.g. the terminate application dialogue does or a manually created kdialog one: kdialog --msgbox "Volume is maximised." --title "Very loud" or a confirmation dialogue whether one really wants to close a window.

Steps to Reproduce:
1. kdialog --msgbox "Volume is maximised." --title "Very loud"
  
Actual results:
Audio volume is maximised, dialogue is shown.

Expected results:
Only show dialogue without changing audio volume.

Additional info:
I had to delete the .kde directory not too long ago, because after using a beamer I had to enlarge KDE's main bar again, which got stuck and froze my system on KDE startup, which prevented me from using it at all. After deleting .kde the system worked fine again, but maybe this is related. It could be regarding the timeline.

Comment 1 Jack B. 2010-12-06 01:45:08 UTC
This is very strange, but the bug seems to be fixed now without me having deliberately changed anything, but we can assume it to be closed, I guess. Esp. since this bug doesn't occur on F14 as well.

Comment 2 Jack B. 2010-12-07 06:00:52 UTC
PLEASE REOPEN BUGREPORT

OK, this bug is really weird: After a restart the very same bug occurs again. It can be provoked in the same way described above.

Comment 3 Jack B. 2010-12-18 14:32:02 UTC
Tried to track down why the bug behaved so strangely. Could be that Amarok is involved: I provoked the bug using Shift+Delete in Dolphin (thus triggering confirmation dialogues) and the volume was maximised each time until I closed Amarok. Then the bug vanished and even after restarting Amarok it didn't occur again until reboot.


Note You need to log in before you can comment on or make changes to this bug.