Bug 660193 - cannot Lock Screen
cannot Lock Screen
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
19
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-05 21:22 EST by Jens Petersen
Modified: 2015-02-17 08:31 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 08:31:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2010-12-05 21:22:50 EST
Description of problem:
I cannot lock the screen when using gnome-shell.

Version-Release number of selected component (if applicable):
F14 and F15 rawhide

How reproducible:
every time

Steps to Reproduce:
1. Click on panel User menu -> Lock Screen
  
Actual results:
nothing

Expected results:
screen to lock

Additional info:
happens for both current F14 and F15 gnome-shell.
Comment 1 Rich Mattes 2011-06-16 13:56:56 EDT
I'm seeing this problem in F15.  When I select "Lock Screen" from the menu in the upper right, nothing happens.  The screen is also unlocked when the machine resumes from suspend or screen saver.  I have the lock screen option in the "Screen" menu in System Settings set to 5 minutes, and the "Lock" slider is on.
Comment 2 Steven Michael Williams 2011-06-21 15:50:45 EDT
I am also suffering from this issue on Fedora 15 (64 bit). It is pretty important because of my role as Network Administrator to keep my screen locked when I am off doing something away from my computer, so no one can open up Seahorse and see my different passwords.
Comment 3 Rich Mattes 2011-08-11 01:03:47 EDT
So I did some digging, apparently gnome-screensaver is responsible for screen locking (maybe this bug should be reassigned).  I checked, and gnome-screensaver isn't running, even though it's checked off in gnome-session-properties.  I tried running gnome-screensaver manually, and got:

$ gnome-screensaver
Illegal instruction (core dumped)

I tried reinstalling gnome-screensaver via a yum reinstall, and when I ran gnome-screensaver on the cli again it didn't crash.  So I logged out and back in again, and gnome-screensaver was running, with screen locking working properly.
Comment 4 Stefan Ring 2012-06-30 10:39:49 EDT
Still not working with Fedora 17. How can this not get any attention? When the unlock screen vulnerability was found, everyone freaked out, but you don't even need the vulnerability if the screen never locks in the first place.
Comment 5 Stefan Ring 2012-07-03 08:50:47 EDT
It turns out that "Screensaver" was not ticked in gnome-session-properties. Why, I have no idea. I certainly didn't un-check it myself, because I hadn't even known about gnome-session-properties. Screen locking works now as a result of me toggling the checkbox (and restarting the session).
Comment 6 Fedora End Of Life 2013-04-03 15:02:14 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 19 development cycle.
Changing version to '19'.

(As we did not run this process for some time, it could affect also pre-Fedora 19 development
cycle bugs. We are very sorry. It will help us with cleanup during Fedora 19 End Of Life. Thank you.)

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora19
Comment 7 Fedora End Of Life 2015-01-09 11:28:33 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 8 Fedora End Of Life 2015-02-17 08:31:46 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.